Ask Your Question
0

fedora pcl and ros

asked 2016-02-03 07:56:45 -0600

Maya gravatar image

Hello all,

I just tried to compile a project using PCL under my Fedora. I am using ROS indigo but I also have jade in case. They both are compiled from source.

I'm hitting this error while compiling :

CMake Error at /home/malcolm/ros_catkin_ws/source_jade/install_isolated/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by "pcl" with any of
  the following names:

    pclConfig.cmake
    pcl-config.cmake

  Add the installation prefix of "pcl" to CMAKE_PREFIX_PATH or set "pcl_DIR"
  to a directory containing one of the above files.  If "pcl" provides a
  separate development package or SDK, be sure it has been installed.

I have PCL installed on my machine :

Installed Packages
pcl.x86_64                                  1.7.2-8.fc23    @fedora
pcl-devel.x86_64                            1.7.2-8.fc23    @fedora
pcl-doc.noarch                              1.7.2-8.fc23    @fedora
pcl-tools.x86_64                            1.7.2-8.fc23    @fedora

And compile a small project under pcl outside of ROS works.

I tried adding places to the CMAKE_PREFIX_PATH

echo $CMAKE_PREFIX_PATH
/home/malcolm/ros_catkin_ws/jade_ws/devel:/home/malcolm/ros_catkin_ws/source_jade/install_isolated:/usr/include/pcl-1.7:/lib64/cmake:/lib64/cmake/pcl

Linking directly to PCLConfig.cmake but it did not change a thing.

Any help on this appreciated :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-03 08:05:57 -0600

Maya gravatar image

I really hate it when I find my answer only after I asked a question :|

Anyway if someone wonders it's because I still had :

find_package(catkin REQUIRED COMPONENTS
  cv_bridge
  geometry_msgs
  pcl
  pcl_ros

in my CMakeLists.txt

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-03 07:56:45 -0600

Seen: 84 times

Last updated: Feb 03 '16