Ask Your Question
0

Failed to install Autoware on Nvidia Jetson AGX Xavier

asked 2019-05-16 03:27:28 -0600

mangSteve gravatar image

updated 2019-05-16 03:35:13 -0600

Hello there,

I am trying to install Autoware on my Jetson Xavier device(Ubuntu 18.04 on ARMv8, 64-bit). I installed ROS melodic and followed https://github.com/autowarefoundation...

I cloned feature/melodic branch and tried to follow the steps.

Everything went fine except that gksu cannot be installed as it is abandoned by Ubuntu 18

But when I run ./colcon_release:

nvidia@jetson-0423218010999:~/Documents/autoware/ros$ ./colcon_release
Starting >>> autoware_build_flags
Starting >>> autoware_msgs
Starting >>> autoware_config_msgs
Starting >>> tablet_socket_msgs                                                             
Finished <<< autoware_build_flags [15.3s]                                                   
Starting >>> vector_map_msgs
Finished <<< tablet_socket_msgs [39.5s]                                  
Starting >>> autoware_system_msgs
[Processing: autoware_config_msgs, autoware_msgs, autoware_system_msgs, vector_map_msgs]
Finished <<< autoware_system_msgs [45.0s]                                           
Starting >>> autoware_health_checker
[Processing: autoware_config_msgs, autoware_health_checker, autoware_msgs, vector_map_msgs]
Finished <<< autoware_config_msgs [2min 13s]                                        
Starting >>> autoware_can_msgs
[Processing: autoware_can_msgs, autoware_health_checker, autoware_msgs, vector_map_msgs]
Finished <<< autoware_can_msgs [37.5s]                                              
Starting >>> gnss                                                                   
Finished <<< gnss [18.4s]                                                           
Starting >>> rslidar_msgs                                                          
--- stderr: autoware_health_checker                                                            
make[2]: *** No rule to make target '/usr/lib/aarch64-linux-gnu/libopencv_objdetect.so.3.2.0', needed by 'devel/lib/autoware_health_checker/health_aggregator'.  Stop.
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [CMakeFiles/health_aggregator.dir/all] Error 2
make: *** [all] Error 2
---
Failed   <<< autoware_health_checker    [ Exited with code 2 ]
Aborted  <<< autoware_msgs                                                                        
Aborted  <<< rslidar_msgs                                                                        
Aborted  <<< vector_map_msgs                                                     

Summary: 6 packages finished [4min 8s]
  1 package failed: autoware_health_checker
  3 packages aborted: autoware_msgs rslidar_msgs vector_map_msgs
  1 package had stderr output: autoware_health_checker
  128 packages not processed

And this is my ROS environment variables

nvidia@jetson-0423218010999:~$ env | grep ROS
ROS_ETC_DIR=/opt/ros/melodic/etc/ros
ROS_ROOT=/opt/ros/melodic/share/ros
ROS_MASTER_URI=http://localhost:11311
ROS_VERSION=1
ROS_PYTHON_VERSION=2
ROS_PACKAGE_PATH=/opt/ros/melodic/share
ROSLISP_PACKAGE_DIRECTORIES=ROS_DISTRO=melodic

Also, it shows that there are libopencv_objdetect.so* files in another dir, but not under the mentioned dir

nvidia@jetson-0423218010999:~/Documents/autoware/ros$ ls /usr/lib | grep libopencv_objdetect
libopencv_objdetect.so
libopencv_objdetect.so.3.3
libopencv_objdetect.so.3.3.1

I am wondering whether it is possible to install Autoware on Xavier.

Any help would be appreciated

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-05-17 02:22:45 -0600

mangSteve gravatar image

Well, finally I reinstalled OpenCV by following https://www.jetsonhacks.com/2018/11/0...

And this seems to solve the error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2019-05-16 03:27:28 -0600

Seen: 783 times

Last updated: May 17 '19