[Solved] Eclipse doesn't see Custom Messages [closed]

asked 2012-04-20 00:17:01 -0500

ercarrion43 gravatar image

updated 2014-01-28 17:12:01 -0500

ngrennan gravatar image

Hi, could someone help me with this?. When I import a package in eclipse and try to import messages types for using in topics eclipse just "see" the Ros predefined ones but not the ones a define. For example

include "package/message.h"


package::message mess;

throws an error if 'package' is a package that I made and message a type I defined in a .msg file. But, for example, with "sensor_msgs/LaserScan.h" it throws no error, eclipse finds the .h.

Despite the eclipse errors, the package compiles well (inside eclipse) and the node sends and receives messages with the custom type. Any ideas? Thanks in advance!

Solved, I just needed to 'make eclipse-project' again and reimport the project. I left the question in case it's useful for somebody else.

edit retag flag offensive reopen merge delete

Closed for the following reason Question does not follow our guidelines for questions. Please see: http://wiki.ros.org/Support for more details. by tfoote
close date 2012-04-20 09:52:55