Ask Your Question
0

[SOLVED]Orientation_mode issue

asked 2019-05-07 03:08:32 -0500

RobertoD gravatar image

updated 2019-05-21 13:51:26 -0500

Hello,

I'm using ROS-indigo on a VM that run Ubuntu-14.04.5. I want to store on a file the informations of "/move_base/NavfnROS/plan" (in particular I need the position and orientation), to do so I first run this launch file:

<launch>

    <!-- Transformations /-->

    <node pkg="tf" type="static_transform_publisher" name="static_transform" args="8.5 21.5 0 1.57079633 0 0 map base_link 100"/>

    <!-- static Map /-->    
    <node pkg="map_server" type="map_server" name="static_map" args="/home/rob/catkin_ws/src/map_server/maps/testmap1.yaml" />

    <!-- move_base + costmap parameters /-->

    <node pkg="move_base" type="move_base" name="move_base" output="screen" >
        <rosparam file="/home/rob/catkin_ws/src/move_base1/move_base_config/costmap_common_params.yaml" command="load" ns="global_costmap" />
        <rosparam file="/home/rob/catkin_ws/src/move_base1/move_base_config/costmap_common_params.yaml" command="load" ns="local_costmap" />
        <rosparam file="/home/rob/catkin_ws/src/move_base1/move_base_config/global_costmap_params.yaml" command="load" />
        <rosparam file="/home/rob/catkin_ws/src/move_base1/move_base_config/local_costmap_params.yaml" command="load" />
    </node>

</launch>

after that I run rviz and use the "2D Nav Goal" button to set a goal in my static_map and let global_planner to generate a path_plan. I finally use rostopic echo /move_base/NavfnROS/plan >> "filel.txt" in the terminal to store the information that I need.

When I read the stored information in "file.txt" I correctly obtain the positions, but the orientation shows always x:0 y:0 z:0 w:1 though i set the "orientation_mode" parameter equal to 1 (FORWARD) in the "costmap_common_params.yaml".

Could anyone tell me what I'm doing wrong? (And yes, I already build the workspace with catkin_make).

The reference link where i read about the "orientarion filter" http://wiki.ros.org/global_planner

Thank you for your help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-21 13:51:08 -0500

RobertoD gravatar image

I found the problem: when I was trying to implement the global planner, I missed this:

<node pkg="move_base" type="move_base" name="move_base" output="screen" >
    <param name="base_global_planner" value="global_planner/GlobalPlanner" />
...
</node>

After that, from rqt_gui->dynamic reconfigure, was simple to change the orientation_mode from none to Forward

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-07 03:08:32 -0500

Seen: 170 times

Last updated: May 21 '19