ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Setting up remote access on a kobuki with a Hokuyo UST-10LX laser

asked 2019-04-10 00:07:22 -0500

ashu gravatar image

updated 2019-04-10 00:08:31 -0500

I am trying to connect to a Raspberry pi with Ubuntu Mate that I use to control the Kobuki, with my laptop for remote access.

I set up the necessary static IPs and set up the necessary ROS_HOSTNAME and ROS_MASTER_URI settings.However, since my Hokuyo laser is connected using Ethernet, the Ethernet connection seems to be getting the preference and the wifi network and internet becomes unusable on the Raspberry.

Is there a way i can circumvent this? Or am I missing something other than the ROS_HOSTNAME and ROS_MASTER_URI settings on both the PCs?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-04-10 01:00:22 -0500

janindu gravatar image

updated 2019-04-10 01:35:15 -0500

You need to set the routing table on the Raspberry pi OS. For an example, let's say the Hokuyo is connected via eth0 with IP address and the IP address of the Raspberri Pi is ROS communication happens via wlan0 where the IP address of the remote PC is and the IP address of the Raspberri Pi is something like, then you need to setup the routing table as follows.

sudo ip route add via dev wlan0

sudo ip route add via dev eth0

You can check if the routing table is configured properly using ip route show command.

After setting the routing table, you can confirm that it's configured properly by pinging and from Raspberri Pi.

edit flag offensive delete link more


Thanks a lot! This was just what I needed.

ashu gravatar image ashu  ( 2019-04-10 02:49:11 -0500 )edit

Question Tools



Asked: 2019-04-10 00:07:22 -0500

Seen: 264 times

Last updated: Apr 10 '19