Ask Your Question
0

costmap2dros transform timeout

asked 2019-04-04 12:04:42 -0500

abraham gravatar image

updated 2019-04-04 12:57:45 -0500

jayess gravatar image

i'm implementing move_base on my own robot description .i used hector slam for mapping and localize the robot amcl correctly. but when i imlement move_base the simulation start to show error the robot doesn't move to a goal .i have search similar question on internet but couldn't find any solution.

[ WARN] [1554394342.080578158, 1481.705000000]: Costmap2DROS transform timeout. Current time: 1481.7050, global_pose stamp: 0.0000, tolerance: 0.3000

i am using skid steering plugin for odometry i can't post my tf because i don't point ,and am using ros kinetic on ubuntu 16.04

base_local_planner_params.yaml

TrajectoryPlannerROS:
  max_vel_x: 0.5
  min_vel_x: 0.1
  max_vel_theta: 0.5
  min_in_place_vel_theta: 0.1
  escape_vel: -0.02

  acc_lim_theta: 0.5
  acc_lim_x: 0.5
  acc_lim_y: 0.5

  sim_time: 4

  meter_scoring: true
  holonomic_robot: false


EBandPlannerROS:
  # Common Parameters
  xy_goal_tolerance: 0.15  
  yaw_goal_tolerance: 0.13  
  rot_stopped_vel: 0.05  

  trans_stopped_vel: 0.05  

  # Visualization Parameters
  marker_lifetime: 20.0  

  # Trajectory Controller Parameters
  max_vel_lin: 0.75  
  max_vel_th: 1.0 
  min_vel_th: 0.5  
  min_in_place_vel_th: 2.0  
  k_prop: 1.0  
  k_damp: 3.5 
  Ctrl_Rate: 50  
  max_translational_acceleration: 2.5  
  max_rotational_acceleration: 1.5  
  differential_drive: true  
  max_acceleration: 2.5

local_costmap_params.yaml

local_costmap:
   global_frame: /odom
   robot_base_frame: base_link
   update_frequency: 10.0
   publish_frequency: 10.0
   width: 20.0
   height: 20.0
   resolution: 0.05
   static_map: false
   rolling_window: true
costmap_common_params.yaml
map_type: costmap

obstacle_range: 5
raytrace_range: 6

footprint: [ [-0.6, -0.85], [-0.6, 0.85], [0.6, 0.85], [0.6, -0.85] ]

transform_tolerance: 0.3

robot_radius: 0.8
inflation_radius: 0.35

observation_sources: laser_scan_sensor
laser_scan_sensor: {sensor_frame: Empty_lidar, data_type: LaserScan, topic: /scan, marking: true, clearing: true}

global_costmap_params.yaml

global_costmap:
   global_frame: /map
   robot_base_frame: base_link
   update_frequency: 5.0
   publish_frequency: 5.0
   resolution: 0.05
   static_map: true
   rolling_window: false

move_base launch

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find roboot1_move_base)/config/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find roboot1_move_base)/config/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find roboot1_move_base)/config/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find roboot1_move_base)/config/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find roboot1_move_base)/config/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find roboot1_move_base)/config/base_local_planner_params.yaml" command="load" />
    <remap from="cmd_vel" to="cmd_vel"/>
    <remap from="odom" to="/odom"/>
    <remap from="scan" to="/scan"/>

    <param name="base_global_planner" type="string" value="global_planner/GlobalPlanner" />
    <param name="base_local_planner" value="eband_local_planner/EBandPlannerROS"/>
    <param name="controller_frequency" value="30.0" />
    <param name="planner_frequency" value="1.0" />
  </node>
</launch>

am beginner please help me with this

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-08 08:22:42 -0500

Drik gravatar image

I had the same problem. You need to check your time setup on your robot. It helped me to install NTP. My robot had a date and time in april 2016.

edit flag offensive delete link more

Comments

Thanks a lot for the answer ,but I solve the problem by making my robot base frame to base_foot_print on my local_costmap_params.yaml a'm not shore why but it is working now.

abraham gravatar imageabraham ( 2019-04-09 07:39:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-04-04 12:04:42 -0500

Seen: 355 times

Last updated: Apr 08