ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

UR5 Robot Kinect Camera Module with UR5 Simulation,

asked 2019-03-21 11:15:07 -0500

Meric gravatar image

I am a beginner in ROS and RViz I would like to get Kinect Module work with UR5 Simulation.

Right now I installed UR5 Library from Universal Robot

After that I installed Openni Kinect Kinetic version on my Ubuntu 16.04. I run these commands:

roslaunch ur_gazebo ur5.launch

And add my Kinect Camera as it is told in the tutorials and my Model.sdf file looks like this:

<?xml version='1.0'?>
<sdf version='1.6'>
  <model name='camera'>
    <link name='link'>
      <pose frame=''>0 0 0 0 -0 0</pose>
      <sensor name='camera' type='depth'>
        <camera name='__default__'>
    <plugin name="camera_plugin" filename="">
          <!-- Keep this zero, update_rate in the parent <sensor> tag
            will control the frame rate. -->
      <visual name='visual'>
        <pose frame=''>0 0 0 0 -0 0</pose>
      <collision name='collision'>
        <pose frame=''>0 0 0 0 -0 0</pose>
            <size>0.073 0.276 0.072</size>
              <fdir1>0 0 0</fdir1>

I run these two command for Rviz simulation as it is in the Universal Robot Git.

roslaunch ur5_moveit_config ur5_moveit_planning_execution.launch sim:=true
roslaunch ur5_moveit_config moveit_rviz.launch config:=true

But cannot set Camera_link which is my Camera frame inside this:

phot of Rviz:

But I cannot see anything as a sensor data. And even there is publishers in rostopic nothing published on them with ... (more)

edit retag flag offensive close merge delete


The main problem might be Fixed Frame in my sdf file doesnt exist on Rviz

Meric gravatar image Meric  ( 2019-03-21 11:27:41 -0500 )edit

I made my Camera Model.sdf to World as URF Rviz simulation frame, Nothing changed, doesnt see anything published

Meric gravatar image Meric  ( 2019-03-21 11:33:32 -0500 )edit

Also Error Log when I insert the Kinect Camera

gzserver: /build/ogre-1.9-mqY1wq/ogre-1.9-1.9.0+dfsg1/OgreMain/src/OgreRenderSystem.cpp:546: virtual void Ogre::RenderSystem::setDepthBufferFor(Ogre::RenderTarget*): Assertion `bAttached && "A new DepthBuffer for a RenderTarget was created, but after creation" "it says it's incompatible with that RT"' failed.
Aborted (core dumped)
Meric gravatar image Meric  ( 2019-03-21 11:48:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-03-21 13:18:44 -0500

Meric gravatar image

updated 2019-03-22 08:20:24 -0500

IT Has nothing to do with Fixed Frame, The Model file can have standalone frame name which should be same with Rviz frame.

Ok After I upgraded to the Gazebo 7.14 Which cost me like nearly a DAY, the problem seem to fixed. I am not sure if is fully fixed but I can see a gray scale image and I can rostopic echo the publishers and some values of arrays comes in.

I wish some one could find this answer usefull. Thanks

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2019-03-21 11:15:07 -0500

Seen: 409 times

Last updated: Mar 22 '19