Ask Your Question
0

build failed for openni driver

asked 2012-04-16 06:19:28 -0600

priya gravatar image

updated 2016-10-24 09:00:16 -0600

ngrennan gravatar image

hi

i have kinect camera and i'm trying to install it in my laptop with 32-bit ubuntu 11.10 and ros electric.so i connected the usb cable from kinect to laptop and started with the steps given in openni_kinect package in ros.org and got following error while trying to run make cmd in drivers:

root@mutu-Vostro-3550:/opt/ros/electric/stacks/drivers# make cd openni && make make[1]: Entering directory `/opt/ros/electric/stacks/drivers/openni' cd build/openni/Platform/Linux/CreateRedist && bash RedistMaker && cd -


  • PrimeSense OpenNI Redist *
  • 2012-04-16 21:21:43 *

Target: Linux-x86 Version: 1.5.2.23 Num of compile jobs: 8

  • Building OpenNI... ../../../../../Source/Utils/niLicense/niLicense.cpp: In function ‘int main(int, char)’: ../../../../../Source/Utils/niLicense/niLicense.cpp:122:108: warning: format ‘%lu’ expects argument of type ‘long unsigned int’, but argument 2 has type ‘unsigned int’ [-Wformat] ../../../../../Source/Utils/niLicense/niLicense.cpp:129:97: warning: format ‘%lu’ expects argument of type ‘long unsigned int’, but argument 2 has type ‘unsigned int’ [-Wformat] /bin/sh: javac: not found make[3]: [../../../Bin/x86-Release/org.OpenNI.jar] Error 127 make[2]: [Wrappers/OpenNI.java] Error 2 make[2]: Waiting for unfinished jobs.... failed to execute: make -j8 -C /opt/ros/electric/stacks/drivers/openni/build/openni/Platform/Linux/CreateRedist/../Build > /opt/ros/electric/stacks/drivers/openni/build/openni/Platform/Linux/CreateRedist/Output/BuildOpenNI.txt Building Failed! make[1]: [installed] Error 1 make[1]: Leaving directory `/opt/ros/electric/stacks/drivers/openni' make: * [openni_lib] Error 2

what should i do?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2012-04-16 07:15:13 -0600

If you're using Ubuntu, you should use the binary packages instead of installing from source:

sudo apt-get install ros-electric-openni-kinect

Also, it looks like you have things in /opt/ros that aren't managed by apt. This is not a good idea and could cause things to act in unexpected ways.

edit flag offensive delete link more

Comments

yes i tried that first step but i got:mutu@mutu-Vostro-3550:~$ sudo apt-get install ros-electric-openni-kinect [sudo] password for mutu: Reading package lists... Done Building dependency tree
Reading state information... Done ros-electric-openni-kinect is already the newest version.

priya gravatar imagepriya ( 2012-04-16 18:35:42 -0600 )edit

Then you already have it installed and can try the launch files here: http://ros.org/wiki/openni_launch . If you get errors about things not being built or not being found, remove all files you added while attempting to do the source build and try again.

Eric Perko gravatar imageEric Perko ( 2012-04-16 20:06:21 -0600 )edit
0

answered 2012-04-17 21:26:15 -0600

priya gravatar image

i installed ubuntu 64 bit and ros again and did the steps for openni_kinect in ros webpage. i got the same error.then i found that i have to install java sdk for 11.10. then i gave make again for drivers it worked.

sudo add-apt-repository ppa:ferramroberto/java sudo apt-get update sudo apt-get install sun-java6-jdk sun-java6-plugin

edit flag offensive delete link more
0

answered 2015-06-03 04:01:45 -0600

Wessi gravatar image

Hi guys, i just solved the same problem by making the installation of following packages ... which adds every needed packages to the usr directory including the update alternatives... good luck sudo apt-get install g++ python libusb-1.0-0-dev freeglut3-dev openjdk-6-jdk doxygen graphviz

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-16 06:19:28 -0600

Seen: 2,005 times

Last updated: Apr 17 '12