Ask Your Question
0

error unable communicate with master

asked 2019-03-12 13:29:34 -0600

gautier gravatar image

updated 2019-03-13 09:08:50 -0600

gvdhoorn gravatar image

Hello,

I'm trying to setup a workstation to work with a Turtlebot.

I've followed the tutorial here : wiki.ros.org/Robots/Turtlebot/Network%20Setup

Robot IP is : 192.168.0.152 Workstation IP is 192.168.0.122

In .bashrc I set up ROS_MASTER_URI in both bashrc at this value : http://192.168.0.152:11311 Both Hostname are set up with the IP of the machine

I can ping in both ways.

Roscore is launched on the robot and rostopic return "/rosout" and "/rosout_agg" But still when I launch "rostopic list" on the workstation, it doesn't work and returns "Unable to connect with master"

Has someone any leads that we could follow please?

Thank you :D

edit retag flag offensive close merge delete

Comments

Have you set the IP of the workstation as ROS id? If workstation isn't properly identified, roscore can't connect it to the topic.

"export ROS_IP=192.168.0.122" in the bashrc file on the workstation?

billy gravatar imagebilly ( 2019-03-12 18:46:55 -0600 )edit

hello, thanks for your answer but the bashrc file already have "export ROS_IP=192.168.0.122" have you other ideas ?

gautier gravatar imagegautier ( 2019-03-13 08:36:41 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-13 08:56:07 -0600

gautier gravatar image

got it !! it was the firewall of the machine link to the robot thanks for your help anyway

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-12 13:29:34 -0600

Seen: 130 times

Last updated: Mar 13 '19