Ask Your Question
1

problem with roslaunch command and Kinect camera_info [closed]

asked 2012-04-14 20:15:55 -0500

PriyankaP gravatar image

updated 2016-10-24 08:33:51 -0500

ngrennan gravatar image

We are using Kinect connected to usb 2.0 port as required and diamondback ROS. Does Kinect need calibration?

We tried

rostopic echo /camera/depth/points

and this is publishing data.

but we tried the roslaunch command and it doesn't start the device but gives an error. we also used

rostopic echo /camera/rgb/camera_info

But this does not publish any data and due to that rviz gives an error on opening.

If it requires calibration, we found, in openni_node.launch this line:

`<rosparam command="load" file="$(file openni_camera)/info/openni_params.yaml"/>.`

Calibration parameters are present in openni_params.yaml that is used in openni_node.launch. Also found some other files in info folder. But still it does not access camera info.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-01-02 12:57:21

Comments

I'm having this same issue: /camera/rgb/camera_info is not publishing any data. Has something changed?

Dave Coleman gravatar image Dave Coleman  ( 2012-04-15 07:43:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-04-14 20:26:25 -0500

K Chen gravatar image

updated 2012-04-14 21:37:28 -0500

Which ros version are you using? In electric you can use

roslaunch openni_camera openni_node.launch

to start the device and rviz to view the published image data.

See wiki here: http://www.ros.org/wiki/openni_camera

Kinect could be used without calibration

UPDATE: As you can see the openni_camera package has a pre-calibrated param file for Kinect, you can calibrate it again but not doing so won't have problem in launching the device.

How did you bring up the device before you can see published /camera/depth/points topic? The openni_camera package is not dramatically changed between Diamondback and Electric. Please post the error message to further investigate the problem.

edit flag offensive delete link more

Comments

I'm using diamondback version.

PriyankaP gravatar image PriyankaP  ( 2012-04-14 20:36:18 -0500 )edit

Question Tools

Stats

Asked: 2012-04-14 20:15:55 -0500

Seen: 524 times

Last updated: Apr 14 '12