How do I run rosdep init without sudo? [closed]

asked 2019-03-07 10:15:26 -0500

barcode gravatar image

updated 2019-03-07 10:16:00 -0500

Hi, I am trying to do a non privileged install of ros melodic and wanted to know whether it is possible to run rosdep without sudo.

When searching online i found this command ( ):

ROSDEP_SOURCE_PATH=/tmp/asdf rosdep init

When i execute it, i get

$ ROSDEP_SOURCE_PATH=/tmp/asdf rosdep init
ERROR: cannot create /etc/ros/rosdep/sources.list.d:
[Errno 13] Permission denied: '/etc/ros/rosdep'

Am i doing something wrong or was this very useful feature removed for some reason?

I appreciate any hints.
- barcode

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by tfoote
close date 2020-12-22 16:46:00.976954


Related: #q276942.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-07 10:19:37 -0500 )edit

Seems like your tmp directory needs to exist first -

Are you sure you it exists?

karnix gravatar image karnix  ( 2019-04-30 12:48:55 -0500 )edit

It did not. Creating the directory fixed it.

barcode gravatar image barcode  ( 2019-05-28 11:08:19 -0500 )edit