Ask Your Question
0

How do you run rosbag2 in ROS2 Crystal?

asked 2019-03-02 11:20:04 -0600

I'm running ROS2 Crystal on Ubuntu 18.04. I've installed the ros-crystal-rosbag2 package, but am not sure how to run it. From the Github readme it looks like this should add a verb to the ROS2 command, but when I run:

ros2 bag record -a

I get the following error:

usage: ros2 [-h] Call `ros2 <command> -h` for more detailed usage. ...
ros2: error: argument Call `ros2 <command> -h` for more detailed usage.: invalid choice: 'bag' (choose from 'daemon', 'extension_points', 'extensions', 'launch', 'lifecycle', 'msg', 'multicast', 'node', 'param', 'pkg', 'run', 'service', 'srv', 'topic')

How do I run rosbag2 in Crystal?

Thanks,

David

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-03-03 16:19:28 -0600

Karsten gravatar image

Please make sure to follow the debian instructions correctly: https://github.com/ros2/rosbag2#debia...

So in particular, the package you installed does only support the API for rosbag2. The actual command line verb gets added by ros-crystal-ros2bag.

edit flag offensive delete link more

Comments

3

Thanks. That fixed it. Having a ros2bag and rosbag2 package is somewhat confusing. Is there any documentation on the difference in the two?

david.hodo gravatar imagedavid.hodo ( 2019-03-05 17:27:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-03-02 11:20:04 -0600

Seen: 233 times

Last updated: Mar 03