Ask Your Question
0

RGBDSLAM GUI not getting data from kinect

asked 2012-04-11 22:03:35 -0600

Naman Goyal gravatar image

updated 2016-10-24 09:03:25 -0600

ngrennan gravatar image

Hey....

I have been trying to run RGBDSLAM with kinect on my PC. I have downloaded openNI drivers as suggested. And Kinect is giving data if i run only openNI launch files.

But when i try to run rgbdslam+kinect.launch, it shows the gui but its not getting data from kinect. Its showing 'Waiting for monochrome image'..... further more i am not using ubuntu on VNware.... please help me out....

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-04-13 05:50:44 -0600

My guess is, that you use openni_launch instead of openni_camera and need to adapt the topics in the launch file:

<param name="config/topic_image_mono"              value="/camera/rgb/image_color"/>
<param name="config/topic_image_depth"             value="/camera/depth_registered/image"/>
<param name="config/topic_points"                  value="/camera/depth_registered/points"/>

Also you need to enable registration of depth and color, e.g. via dynamic_reconfigure. See this answer for how to enable registration by default.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-11 22:03:35 -0600

Seen: 758 times

Last updated: Apr 13 '12