Ask Your Question
0

Rtabmap with Tango ROS streamer; rtabmap 'Did not receive data since 5 seconds!'

asked 2019-02-26 09:27:13 -0600

swiss_knight gravatar image

Hello,

I'm running ROS melodic 1.14.3 on Ubuntu 18.04 64 bit (kernel: 4.15.0-45-generic x86_64 GNU/Linux) (and I'm a total beginner with ROS, don't hesitate to ask for more commands' outputs if needed).

I'm trying to map a room from an Android 6.0.1 Lenovo Phab 2 pro smartphone where I installed the "Tango ROS Streamer" application ( https://play.google.com/store/apps/de... ).

I can connect to the ROS Master on the laptop from the phone.
I can see incoming pictures from the fish-eye and the color cameras on the laptop.
I can see the live point cloud from Tango using $ rosrun rviz rviz -d /path/to/tango_config_file . The config file was downloaded from the link at point 2 of this page : http://wiki.ros.org/tango_ros_streame... , which is this one: https://github.com/Intermodalics/tang...

But when I try to follow the rtabmap + Tango tutorial from here: http://wiki.ros.org/rtabmap_ros/Tutor... I get stuck with 2 warnings.
From the previous webpage, everything is working up to point 4. I can see updates from the /tango/point_cloud topic.
Point 5 seems OK in a new terminal:

$ rosrun rtabmap_ros pointcloud_to_depthimage cloud:=/tango/point_cloud camera_info:=/tango/camera/color_1/camera_info _fixed_frame_id:=start_of_service _decimation:=8 _fill_holes_size:=5
[ INFO] [1551193102.094838430]: Initializing nodelet with 4 worker threads.
[ INFO] [1551193102.647795400]: Params:
[ INFO] [1551193102.647839474]:   approx=true
[ INFO] [1551193102.647929972]:   queue_size=10
[ INFO] [1551193102.647968631]:   fixed_frame_id=start_of_service
[ INFO] [1551193102.648015507]:   wait_for_transform=0.100000s
[ INFO] [1551193102.648036083]:   fill_holes_size=5 pixels (0=disabled)
[ INFO] [1551193102.648053149]:   fill_holes_error=0.100000
[ INFO] [1551193102.648071092]:   fill_iterations=1
[ INFO] [1551193102.648086249]:   decimation=8

And at point 6 I have two warnings printed every 5 seconds:

[ WARN] [1551193180.898167458]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). Parameter "approx_sync" is false, which means that input topics should have all the exact timestamp for the callback to be called.
/rtabmap/rtabmap subscribed to (exact sync):
   /tango/camera/color_1/image_raw_relay,
   /image_relay,
   /tango/camera/color_1/camera_info,
   /rtabmap/odom_info

Followed by:

[ WARN] [1551193181.360817636]: /rtabmap/rtabmapviz: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). Parameter "approx_sync" is false, which means that input topics should have all the exact timestamp for the callback to be called.
/rtabmap/rtabmapviz subscribed to (exact sync):
   /tango/camera/color_1/image_raw_relay,
   /image_relay,
   /tango/camera/color_1/camera_info,
   /rtabmap/odom_info

And an empty visualization rtabmapviz window.

I wonder if I must change something in the called rtabmap.launch file that was bunddled with the ros-melodic-rtabmap and/or ros-melodic-rtabmap-ros packages (I installed them with apt-get, they were not build.) ?

If this helps, here ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-27 17:08:06 -0600

matlabbe gravatar image

I cannot reproduce the problem on my system with binary version (same as you) or with source. It should not subscribe to /rtabmap/odom_info, not sure why on your system it is, unless a previous launch of rtabmap.launch was done without any parameters, so that subscribe_odom_info would have been set to true, then on restarting rtabmap.launch with the tango parameters, subscribe_odom_info was still to true. Try to restart the roscore and try again. If it was the problem, the current version from source already clear all parameters on exit to avoid those kind of problems. Otherwise, you would have to explicitly set all subscribe_odom_info parameters to false in rtabmap.launch.

cheers,
Mathieu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-26 09:27:13 -0600

Seen: 85 times

Last updated: Feb 27