Ask Your Question
0

roscore doesn't output anything.

asked 2019-02-21 13:53:49 -0500

spiritninja gravatar image

I'm using ROS Indigo on Ubuntu 14.04.

Strangely enough, running roscore doesn't output anything as it should.

Running roswtf shows the following output

ROS_IP may be incorrect : ROS_IP [192.168.0.51] does not appear to be a local IP address ['127.0.0.1', '100.69.117.246'] ROS_MASTER_URI is [ http://192.168.0.200:11311 ]

I agree that there are similar questions on here which have already been answered. But trying those solutions and changing the IP in .bashrc file did't affect the issue or I might be going wrong somewhere which i'm unable to figure out.

Thanks.

edit retag flag offensive close merge delete

Comments

Can you clarify why you are setting ROS_IP? Setting that to an incorrect value most likely is the cause here.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-21 14:23:12 -0500 )edit

@gvdhoorn I reset ROS_IP because I found out that it had been changed to some other value upon checking my system IP. roscore was working fine before and as I keep a copy of my .bashrc if I make changes, i noticed the IP value had changed in this file. Hence i tried setting it back.

spiritninja gravatar image spiritninja  ( 2019-02-21 22:14:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-02-21 16:43:03 -0500

lucasg gravatar image

updated 2019-02-21 16:44:47 -0500

Assuming that you are running roscore on the local machine, open a terminal and try the following:

$ ifconfig

This will show you your ip address, among other info.

Once you find out what your ip address is, in terminal type the following at the bottom:

$ echo $ROS_MASTER_URI

and

$ echo $ROS_IP

Ensure that these match what you found in the first step.

If not, go in to your /.bashrc and type the following

 export ROS_MASTER_URI=http://**your_ip_address**:11311 
 export ROS_IP=**your_ip_address**

Either re-source your .bashrc or close terminal and re-open a new one before running another roscore.

edit flag offensive delete link more

Comments

Thank you @lucasg I had to reset the IP and MASTER addresses to the address shown in the warning by roswtf. As ROS is running on the local machine, the catch was that the address in my export lines were changed to one with which the system couldn't ping itself.

spiritninja gravatar image spiritninja  ( 2019-02-22 00:04:25 -0500 )edit

Unlike the usual 127.0.0.1 for localhost, the other address worked. Apart from ifconfighostname -I was helpful in verifying whether the address was a localhost or not.

spiritninja gravatar image spiritninja  ( 2019-02-22 00:10:27 -0500 )edit

Setting ROS_IP and ROS_MASTER_URI to values other than the defaults is typically only needed in special cases. Make sure you actually need to do this, as you've already found out that incorrect values can lead to problems (which may be hard to diagnose).

gvdhoorn gravatar image gvdhoorn  ( 2019-02-22 10:15:51 -0500 )edit

Indeed @gvdhoorn . I wouldn't have changed the addressed but for reasons unknown my localhost address has started changing which I hadn't encountered earlier and hence the same had to be reflected in .bashrc for roscore to run again. I doubt if it has anything to do with export DISPLAY. Thanks

spiritninja gravatar image spiritninja  ( 2019-02-25 04:43:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-21 13:53:49 -0500

Seen: 515 times

Last updated: Feb 21 '19