Ask Your Question
0

How to unlock catkin make ?

asked 2019-11-13 06:55:37 -0600

Juliette_ROS gravatar image

Hello,

I am working on ROS Indigo, and I have a problem with Catkin Make :

I work on a collaborative project, and it seems that a previous student working on this project has locked the "catkin make" command. When I add a new program in the catkin workspace and try to build it with catkin make, it seems that it doesn't do anything : I don't get an error message but nothing is built.

Does anybody know how to solve this issue ?

Thank you,

Juliette

edit retag flag offensive close merge delete

Comments

Is it really catkin_make that you're using, or catkin build? The latter allows configuration of white and blacklists.

catkin_make also supports white and blacklists, but I'm not sure whether those are persisted anywhere.

gvdhoorn gravatar imagegvdhoorn ( 2019-11-13 08:50:33 -0600 )edit

@gvdhoorn When building with catkin_make -DCATKIN_WHITE/BLACKLIST_PACKAGES the file build/catkin_generated/order_packages.py is overwritten to keep the white/blacklisted packages.

Delb gravatar imageDelb ( 2019-11-13 09:53:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-13 09:49:17 -0600

davidem gravatar image

updated 2019-11-13 11:30:30 -0600

Hi Juliette,

I work on a collaborative project, and it seems that a previous student working on this project has locked the "catkin make" command

That doesn't sound right to me. What do you mean by "locked"?

Anyway, the command should be catkin_make with an underscore instead of a space. If that doesn't solve your issue, I see two possible reasons:

  • As @gvdhoorn said in the comment, a blacklist could have been set. I'm not sure if this setting is saved in the workspace or in the local PC of each user. To revert to original settings, try to run catkin_make -DCATKIN_WHITELIST_PACKAGES=""

  • Pay attention to any possible CATKIN_IGNORE files in the root of the package. Those files (without any extension) are used to ignore the package from being built, kinda like a rule on a .gitignore file. If the package that contains the program you wrote has this kind of file in its root, delete it and repeat catkin_make

Extra infos sources about catkin_make whitelists/blacklists and CATKIN_IGNORE

edit flag offensive delete link more

Comments

Hello, I tried to run catkin_make -DCATKIN_WHITELIST_PACKAGES="" but it failed when trying to build one of my new packages, giving this error message : invoking "make-j4-l4" failed

Juliette_ROS gravatar imageJuliette_ROS ( 2019-11-14 07:50:02 -0600 )edit

I deleted catkin_ignore file in catkin_ws but it didn't change anything..

Juliette_ROS gravatar imageJuliette_ROS ( 2019-11-14 07:58:00 -0600 )edit

You said in your question that you didn't get an error message so the whitelist might have solved that or are you still getting the same behavior as in the initial question ?

It just seems that your new packages can't compile due to some errors in your code but that doesn't seem to be related to your question anymore.

Delb gravatar imageDelb ( 2019-11-14 08:19:05 -0600 )edit

invoking "make-j4-l4" failed

that is not the exact error, it means that the compiling failed. edit your question and post all the log error that you receive after running catkin_make

davidem gravatar imagedavidem ( 2019-11-14 09:06:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-11-13 06:55:37 -0600

Seen: 32 times

Last updated: Nov 13