Ask Your Question

ROS not running well on windows 10?

asked 2019-02-14 10:34:07 -0600

imcardle gravatar image

updated 2019-02-26 05:20:24 -0600

gvdhoorn gravatar image

I'm new to ROS, and I am following the tutorials for Windows, starting from here

I know that the windows support is experimental, so I can expect a few glitches - but maybe someone else has seen these problems and knows how to fix (or workaround) them? Let me explain...

  1. The first time I ran rViz I could not get the visualisation panel or the MoveIt! motion planning plug in panel to show up. After a bit of messing around, adding the panels, removing them again, adding them again, saving and closing rViz, re-launching rViz, I go them to show up.

  2. After another few cycles of launching and closing rViz to try some further tutorials, I found that the panels would randomly disappear and I needed to add them back in again. It is as though the layout is not being saved properly?

  3. Now, after yet more cycles of launching and closing rViz, it has finally stopped working completely! When I launch the tool it just creates an empty window with no content at all (no title bar, panels, or grid - nothing!).

I'm using the panda_moveit_config package from the MoveIt! tutorials and I'm launching it using the following procedure:

  • Start an elevated command window.
  • Run the ROS setup script (c:\opt\ros\melodic\x64\setup.bat).
  • Run the MoveIt! setup script (c:\moveit_ws\devel\setup.bat).
  • Launch rViz with panda_moveit_config (roslaunch panda_moveit_config demo.launch).

Please can someone tell me where to look for a solution, or how I can workaround it?

Failing that, perhaps some instructions on how to restore my environment by uninstalling/re-installing rViz on my windows 10 environment? I'm completely new to this, so I really don't know where to start!

Edit: @Sean Yen,

Thanks for sharing details of the fix for this issue.

I updated ROS and MoveIt! today using these commands:

choco upgrade ros-melodic-desktop -y choco upgrade ros-melodic-moveit -y

Then I tried to run the MoveIt! example using this command:

roslaunch panda_moveit_config demo.launch

Now, when rViz runs, I get a different problem! An error message appears and no matter how many times I click on "OK" the message just re-appears. I don't have enough points yet in this forum to upload a screenshot of the error message, but this is what it says:

The procedure entry point could not be located in the dynamic link library c:\opt\ros\melodic\x64\lib\robot_state_publisher\robot_state_publisher.exe

I checked that the "robot_state_publisher.exe" file exists in the path mentioned in the message.

In the command window, another message tells me that "[robot_state_publisher-3] process has died" and gives an exit code of "-1073741511".

Please can you suggest how I can diagnose/fix this problem?

edit retag flag offensive close merge delete


@imcardle Can you try to enter full-screen mode (F11) and exit to see if it helps? which seems to work for me. And it seems to be some race conditions based on some preliminary investigation but not yet root cause the problem yet. See

Sean Yen gravatar image Sean Yen  ( 2019-02-15 03:08:39 -0600 )edit

Thank you so much Sean - F11 followed by exit has got me up and running again! Now I am able to workaround the issue and continue with the tutorials. Hope you can find the root cause and fix it soon!

imcardle gravatar image imcardle  ( 2019-02-15 03:35:20 -0600 )edit

@imcardle, I believe the issue should be resolved in newer ROS on Windows installation, please take some time to upgrade your environment and let me know any issues there. Thanks! JFYI, the details can be found:

Sean Yen gravatar image Sean Yen  ( 2019-02-20 20:28:35 -0600 )edit

@imcardle: could I ask you to please not post answers unless you are answering your own question? For everything else, please edit your original question text (append new information) or for short things, use comments.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-26 05:22:32 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-02-16 11:13:44 -0600

tfurgerson gravatar image

Running VMware Player (free for non-commercial use) will allow you to keep things standard. You can run ROS on Ubuntu in a virtual machine right there on your Windows 10 desktop. The best of all worlds. Works great.

edit flag offensive delete link more



Personally I would not recommend doing this, especially not if you're going to be using RViz with complex scenes in combination with Gazebo.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-16 11:23:22 -0600 )edit

True, it's not for everyone. But for those already running Windows, it's at minimum a good approach for dipping your toes in the waters of both Ubuntu and ROS. Who knows, you might find yourself diving right in.

tfurgerson gravatar image tfurgerson  ( 2019-02-16 13:49:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2019-02-14 10:34:07 -0600

Seen: 1,245 times

Last updated: Feb 26 '19