Ask Your Question
0

Robots always make extra rotations in automatic navigation

asked 2019-02-03 18:31:00 -0500

mydansun gravatar image

I am learning auto-navigation in the simulator, I set a target point in Rviz that is very close to the starting position. The robot then begins to spin and the console tells me that he is clearing the costmap and that he still cannot reach the target point after multiple rotations. The console then displays oscillating over and over. I want to know how to avoid this rotation. Which program trigger this clearing action?

edit retag flag offensive close merge delete

Comments

Not a lot of definitive info in your post. I assume you are useing move_base. Read the wiki, there are parameters to disable recovery behaviors. Like clearing_rotation_allowed . If the robot is consistently over turning try setting limits to acceleration

Reamees gravatar image Reamees  ( 2019-02-04 01:16:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-02-13 19:35:30 -0500

Namal Senarathne gravatar image

Very little information to go with. So I have to make some assumptions. I assume the robot starts to rotate immediately after setting the goal and the goal you set is in the free space and the robot is not too close to any obstacle/wall. This behavior could very well be a problem with Gazebo (if you are using gazebo) simulator generating spurious laser returns near the robot.

If this is your scenario, the best way is to visualize your laser data and local costmap in Rviz and see if the simulation generates these noise. I faced this several times and one solution is to reduce the frequency of the laser in the urdf specification.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-02-03 18:31:00 -0500

Seen: 281 times

Last updated: Feb 13 '19