Ask Your Question
0

PointCloud Input to costmap_2d

asked 2012-01-25 09:33:17 -0500

David Lu gravatar image

updated 2012-01-25 09:33:53 -0500

I am trying to add an additional PointCloud to the costmap_2d list of things to avoid (when doing PR2 navigation). I have added the proper information to the observation_sources parameter.

However, my PointCloud is not being avoided properly, despite the move_base node subscribing to the topic. When comparing my PointCloud messages to the /ground_object_cloud PointCloud data, I noticed that that PointCloud had four Channels of extra data: intensities, index, distances, and stamps. Are these necessary input for costmap_2d, and if so, what do they mean?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-01-26 10:41:53 -0500

David Lu gravatar image

updated 2012-01-26 10:42:23 -0500

It turned out that the problem was not the parameters Lorenz mentioned (although he helped me narrow down the possibilities, for which I'm grateful). It turns out that just changing the frame helped.

I had originally been trying to add points in the /map frame (related to my previous question) which wasn't being processed by the cost map. I changed the node that was publishing the points to translate them to /base_laser_link and that fixed the problem, at least for now (in that it is taking the points into consideration, even if it sometimes causes problems).

I haven't dug into the code yet to figure out if that is a bug or a feature yet.

edit flag offensive delete link more

Comments

Is there any chance you can post your .yaml file for this? I am attempting to get costmap_2d to subscribe to /kinect2/hd/points but it seems my parameters are not correct. Thanks.

skynet gravatar image skynet  ( 2018-04-05 11:49:37 -0500 )edit
1

answered 2012-01-25 19:30:00 -0500

Lorenz gravatar image

We were using PointClouds that contain only points and no additional channels without a problem. My guess would rather be that the other observation sources maybe clear the points of your cloud again. I would first uncomment all observation sources but your additional point cloud. If that works, you can start playing around with the parameters observation_persistence, clearing and marking.

edit flag offensive delete link more

Comments

I forgot about the clearing bit. Thanks for the tip,
David Lu gravatar image David Lu  ( 2012-01-26 04:42:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-25 09:33:17 -0500

Seen: 1,636 times

Last updated: Jan 26 '12