Camera plugin failed to Load on Crystal

asked 2019-01-25 03:51:41 -0500

poonam1120 gravatar image

Hi All,

I followed this tutorial "http://gazebosim.org/tutorials?tut=ros2_installing&cat=connect_ros"

When I am trying any camera related world file,

> gazebo --verbose  /opt/ros/crystal/share/gazebo_plugins/worlds/gazebo_ros_camera_triggered_demo.world

it throws error as

 [Err] [Plugin.hh:180] Failed to load plugin libgazebo_ros_camera.so: libCameraPlugin.so: cannot open shared object file: No such file or directory.

libgazebo_ros_camera.so is present in the /opt/ros/crystal/lib. I am trying it on Ubuntu 18.04 crystal.

Thanks in advance.

edit retag flag offensive close merge delete

Comments

I solved this by following below steps:- Created new workspace and copied only gazebo_plugin project in that. Locate libCameraPlugin.so

$ locate libCameraPlugin.so
/usr/lib/x86_64-linux-gnu/gazebo-9/plugins/libCameraPlugin.so

Copy it manually to the install locatio

poonam1120 gravatar imagepoonam1120 ( 2019-02-07 02:13:23 -0500 )edit

Thanks -- this fixed it for me, too. But why is this failing in the first place? I'm still stumped.

clyde gravatar imageclyde ( 2019-02-10 13:49:08 -0500 )edit

I faced the same issue on ROS Dashing today. A less intrusive way to solve it is to source the gazebo setup file before running gazebo:

. /usr/share/gazebo-9/setup.sh && gazebo --verbose  /opt/ros/dashing/share/gazebo_plugins/worlds/gazebo_ros_camera_triggered_demo.world
marguedas gravatar imagemarguedas ( 2019-06-05 07:24:21 -0500 )edit