Ask Your Question
1

building rosjava_core

asked 2012-04-02 23:41:02 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I was trying to reinstall rosjava_core from source. I uninstalled debian rosjava_core, and downloaded the newest version from source hg clone https://rosjava.googlecode.com/hg/ rosjava_core. Then I tried to follow this tutorial (There seems to be an update for the rosjava_core on 31.March. the following two steps are deleted

./gradlew rosjava_bootstrap:install
rosrun rosjava_bootstrap install_generated_modules.py rosjava

). but as I run ./gradlew install the follwing failure occured. it was no problem when I first installed rosjava from debian... I noticed this is a problem when installing docs. I don't actually need them. can I skip this step?

...
> Building > :docs:javadoc > Resolving dependencies ':rosjava_tutorial_pubsub:co:docs:javadoc
/home/evelyn/ros_workspace/rosjava_core/apache_xmlrpc_server/src/main/java/org/apache/xmlrpc/webserver/WebServer.java:72: warning - Tag @Link: reference not found: ServletWebServer
1 warning
:docs:install
sphinx-build -b html -d build/doctrees   src/main/sphinx build/html
Running Sphinx v1.0.1
loading pickled environment... not yet created
building [html]: targets for 5 source files that are out of date
updating environment: 5 added, 0 changed, 0 removed
reading sources... [ 20%] best_practices
reading sources... [ 40%] building
reading sources... [ 60%] getting_started
reading sources... [ 80%] index
reading sources... [100%] overview

looking for now-outdated files... none found
pickling environment... done
checking consistency... done
preparing documents... done
writing output... [ 20%] best_practices
writing output... [ 40%] building
writing output... [ 60%] getting_started

Exception occurred:
  File "/usr/lib/python2.7/dist-packages/pygments/lexers/__init__.py", line 80, in get_lexer_by_name
    raise ClassNotFound('no lexer for alias %r found' % _alias)
ClassNotFound: no lexer for alias u'groovy' found
The full traceback has been saved in /tmp/sphinx-err-nCDX3T.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at <http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!
make: *** [html] Error 1

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':docs:install'.
> Command 'make' finished with (non-zero) exit value 2.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 19.881 secs
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-04-03 07:48:31 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Had the same issue, inside your rosjava_core directory, there should be a file called settings.gradle. Open it up with your favorite editor, and after the comment header there is a line that says include 'rosjava_bootstrap' etc etc. The last one is 'docs', simply comment out that part and the install worked for me.

edit flag offensive delete link more
1

answered 2012-04-03 22:12:03 -0500

damonkohler gravatar image

You have an outdated version of pygments installed. You can either do as Jyo suggested or call ./gradlew install -x docs:install to exclude building the documentation.

edit flag offensive delete link more

Comments

As a note, it looks like syntax highlighting for Groovy (the language backbone that Gradle uses) was added to pygments in version 1.5 (http://pygments.org/docs/lexers/)

jbohren gravatar imagejbohren ( 2012-04-04 22:15:40 -0500 )edit
0

answered 2012-04-06 06:05:09 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

As the others have said, your version of Pygments is too old. You can upgrade it through python's easy_install (even on Ubuntu 10.04) like so:

sudo easy_install Pygments
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-02 23:41:02 -0500

Seen: 348 times

Last updated: Apr 06 '12