ROS Install hangs on Mac OS Lion [closed]

asked 2012-04-01 23:00:34 -0600

adam gravatar image

updated 2012-04-02 13:17:37 -0600

Kevin gravatar image

Hi,

I'm trying to install and run ROS on Mac OS 10.7 on a MacBook Pro, and I'm using the homebrew instructions at http://www.ros.org/wiki/electric/Installation/OSX/Homebrew. I proceed through the steps successfully until 1.6 when i enter

rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no"

and the download completes sucessfully ( i think), then the last lines are

(Over-)Writing setup.sh, setup.bash, and setup.zsh in /Users/adamhaber/ros Bootstrapping ROS build Detected ros_comm bootstrapping it too.

before the install hangs. The issue may be similar to this one http://answers.ros.org/question/30339/ros-installation-on-mac-with-homebrew but I have tried the recommendations for that to no avail.

Any help would be much appreciated

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-05-01 07:30:28

Comments

I cannot reproduce your problem, but I did run into issues with rosinstall. Ticket and patch here: https://kforge.ros.org/vcstools/trac/ticket/36 Try running sudo pip install --upgrade rosinstall vcstools and try again.

William gravatar imageWilliam ( 2012-04-02 12:59:21 -0600 )edit

hi william, thanks for your response! i ran your suggested upgrade of rosinstall, unfortunately the install hangs in exactly the same place! any ideas how to troubleshoot this issue?

adam gravatar imageadam ( 2012-04-11 15:25:33 -0600 )edit

Adam, I am still unable to reproduce this bug. Can you put the complete output of rosinstall in a gist.github.com and add it to the original question?

William gravatar imageWilliam ( 2012-04-13 09:45:06 -0600 )edit