Upgrade cmake

asked 2018-11-26 02:18:29 -0500

saito gravatar image

updated 2019-01-09 03:30:45 -0500

jayess gravatar image

Hello. I am a ROS beginner. I am doing SLAM of turtlebot 2 in the ubuntu 14.04, ros (indigo) personal computer environment.

when,building,the error is occured.

CMake Error at navigation/amcl/CMakeLists.txt:1 (cmake_minimum_required):
  CMake 3.1 or higher is required.  You are running version 2.8.12.2

so,I upgraded CMake at cmake version 3.8.2 With reference to this.

then,when I input the command "cmake --version","cmake version 3.8.2" is showed.

however,when I try building,The same error is displayed.

I think that I made a mistake at link number 6. How can I do it?

edit retag flag offensive close merge delete

Comments

Are you trying to build from source or have you installed the package amcl with sudo apt-get ? For indigo in the CMake there is the line cmake_minimum_required(VERSION 2.8.3) but it's set to VERSION 3.1 in melodic (which is your error and shouldn't be the case).

Delb gravatar imageDelb ( 2018-11-26 02:37:32 -0500 )edit

It's likely that @saito is trying to build the melodic-devel branch on Indigo.

gvdhoorn gravatar imagegvdhoorn ( 2018-11-26 02:46:25 -0500 )edit

thank you. The link of ros.org was wrong. Correctly it was https://github.com/ros-planning/navig... . Then it went well. Thank you.

saito gravatar imagesaito ( 2018-11-26 04:33:46 -0500 )edit