Ask Your Question
0

CLion not-catkin packages

asked 2018-11-22 08:45:35 -0500

Peter1 gravatar image

I am using CLION for development of ROS C++ files. In my project some files are not catkin compatible but standalone CPP packages. When loading the top level CMakeLists into CLion, I receive an error, because it apparently evokes catkin_make

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkin_workspace.cmake:95 (message):
  This workspace contains non-catkin packages in it, and catkin cannot build
  a non-homogeneous workspace without isolation.  Try the
  'catkin_make_isolated' command instead.

How can I configure CLion to be able to load my entire workspace with catkin_make_isolated or catkin build

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-29 17:01:14 -0500

Benyamin Jafari gravatar image

updated 2019-03-29 17:05:24 -0500

  1. Install ROS-Robot Operating System plugin on CLion:

    you have to open the Settings (from the File menu); then from the left panel select plugin in order to show the plugin panel in the right side and select the marketplace tab; then search for ROS-Robot Operating System plugin and install it.

  2. Import your ros_workspace by the installed plugin in File menu:

    In order to import an existing workspace, you have to use the menu Import ROS workspace, selecting the workspace folder. In this case, the plugin will search from the configured ROS versions and it will setup the project in order to resolve the ROS dependency.


Reference

edit flag offensive delete link more

Comments

Doesnt help... you still get the same error message. We need a way to handle building non catkin packages in clion

airfield20 gravatar imageairfield20 ( 2019-06-03 17:45:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-11-22 08:45:35 -0500

Seen: 242 times

Last updated: Mar 29