Ask Your Question
0

make eclipse-project roslib error

asked 2012-03-29 04:31:53 -0500

prince gravatar image

updated 2014-01-28 17:11:47 -0500

ngrennan gravatar image

Greeting, I am trying to import sbpl into eclipse. I am getting following error.

:/opt/ros/diamondback/stacks/motion_planners/sbpl$ make eclipse-project 
mv Makefile Makefile.ros
cmake -G"Eclipse CDT4 - Unix Makefiles" -Wno-dev .
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
[rosbuild] Building package sbpl
[rosbuild] Error from syntax check of sbpl/manifest.xml
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named roslib.manifest
CMake Error at /opt/ros/diamondback/ros/core/rosbuild/private.cmake:87 (message):
  [rosbuild] Syntax check of sbpl/manifest.xml failed; aborting
Call Stack (most recent call first):
  /opt/ros/diamondback/ros/core/rosbuild/public.cmake:154 (_rosbuild_check_manifest)
  CMakeLists.txt:4 (rosbuild_init)


-- Configuring incomplete, errors occurred!
make: *** [eclipse-project] Error 1

I am getting it with all the packages. Earlier everything was fine! Could it be because of some change in settings by ROS Electric. I installed Electric from Ubuntu debs.

echo $PYTHONPATH 
/opt/ros/diamondback/ros/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games::/opt/ros/diamondback/ros/core/roslib
echo $ROS_PACKAGE_PATH 
/opt/ros/diamondback/stacks

Could it be related to PYTHONPATH variable ??

prince

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2012-04-13 00:07:27 -0500

I noticed two things which are strange in your output:

  1. You talk about Electric, but your paths show Diamondback. Do the errors persist after running the following command?

    source /opt/ros/electric/setup.bash
    
  2. Probably unrelated to your specific problem, but still important: You seem to be running make eclipse-project in a directory outside of your home directory, specifically /opt/ros/diamondback/.... This is evil. This directory tree should not be writable by a normal user, because it is managed by the Debian package manager (in the best case, Linux will simply refuse to let you change files there; in the worst case, you have changed the permissions or run the commands as root to bypass that security precaution). Debian updates will silently overwrite your changes, and more importantly, if you mess up something there, the resulting bugs are hard to track. If you have already changed something there, please remove all ROS-related Debian packages, delete /opt/ros/... and start over. Whenever you feel the need to edit something in /opt/..., instead copy the package/stack over to your home directory first.

Just to make sure, I don't mean to sound rude or impatient; non-writability of /opt/ros/... is a concept that many people get wrong, but I've seen it to cause pain a lot. :-)

edit flag offensive delete link more

Comments

i agree about non-writability of /opt/ros/.. . It is just that while importing the project in eclipse, i make a local copy in my workspace. Your suggestion of making a copy of package itself also makes sense.

prince gravatar image prince  ( 2012-04-13 02:06:15 -0500 )edit

I have both releases, Electric and Diamondback, installed. Problem started after electric installation ! Somehow my pythonpath got screwed. later i added ${ROS_ROOT}/ros/core/roslib/src to PYTHONPATH and it worked.

prince gravatar image prince  ( 2012-04-13 02:07:48 -0500 )edit

You can have both Electric and Diamondback installed in parallel. By sourcing the correct setup.bash file (as explained above), your Pythonpath should be set correctly.

Martin Günther gravatar image Martin Günther  ( 2012-04-13 02:55:59 -0500 )edit
0

answered 2012-04-12 01:00:34 -0500

Angus gravatar image

Hello, I just had a similar error with

[rosbuild] Syntax check of ${PROJECT_NAME}/manifest.xml failed

that was solved by doing a '$make clean' in the package directory and rebuilding normally. Good luck!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-29 04:31:53 -0500

Seen: 986 times

Last updated: Apr 13 '12