proj_map and grid_map issues

asked 2018-11-01 07:23:38 -0500

Aviad gravatar image

Hello, I am trying to localize my real robot with a saved map for navigation propose. I did all the instructions for the navigation (I am using RTABmap) and when I press on the "Nav 2D goal" I can see thr trajectory line of the global planner and than the robot doesn't stop turning in place (I think that it tried to localize itself and the map). Then I noticed that the "grid_map" topic and the "proj_map" topic are sent with a matrix of -1 only. In addition, the cloud_map topic is full in letters and symbols. Its seems that the rtabmap doesn't works properly and maybe it is because I updated the rtabmap and rtabmap_ros lastly. I use the "depthimage to laserscan" package and I get a nice 2D map. I don't know where is the problem I tried many things. I am using "Kinetic" distribution on Ubuntu 16.04, odometry by tencoders only, "move_base" planner.

Here a image of the 2D of the grid_map:

Also a waning from terminal:

Thank Aviad

edit retag flag offensive close merge delete


Can you detail which launch files are used? You referred to rtabmap and amcl_localization in your tags, how did you created the map and which package are you using for localization?

matlabbe gravatar image matlabbe  ( 2018-11-02 15:12:19 -0500 )edit