RosAria not receiving messages

asked 2018-10-29 09:47:27 -0500

owengall gravatar image

#Resources Macbook Air with Ubuntu virtual machine via VMWare
Pioneer3 AT robot

#Context I have at least most of the setup for Ros+RosAria already working:

  1. The master ROS node running on a laptop at via roscore
  2. The RosAria node running on the robot’s built-in computer at via rosrun rosaria RosAria, the port set accordingly to access the robot's motors and sensors via rosparam set..., ROS_MASTER_URI=, and ROS_IP=
  3. Another terminal window on the laptop running rostopic pub /RosAria/cmd_vel geometry_msgs/Twist “linear:... angular:...”

The RosAria node running on the robot confirms it’s able to connect to the master, and if I run the command rostopic list on the laptop I can see /RosAria/cmd_vel as one of the available topics.

In the terminal window where I try to publish to /RosAria/cmd_vel I’m told that the message is sending but the robot shows no signs of having received it, neither console message nor movement of the wheels.

However, if I quit the RosAria node on the robot and restart it while leaving the rostopic pub command running on my laptop, the robot registers the message once upon startup, moves accordingly for a bit, and then does nothing.

I’ve also tried to rostopic echo other topics like battery state, motors status and pose, but I don’t receive any messages from the robot.

I already tried changing the parameters /RosAria/TicksMM and /RosAria/RevCount according to this case.

#Question _Why is the Pioneer robot with RosAria running not receiving the cmd_vel commands from my client if it’s apparently able to communicate with the master node successfully?_

#Disclaimer The project I was working on where this question came up changed, and as a result I’m not currently using this equipment anymore. So I can’t really test suggested solutions and it’s no longer an emergency, though I still wanted to post the question since I was having issues asking it before.

edit retag flag offensive close merge delete


Can you please post the value of ROS_MASTER_URI and ROS_IP for all computers involved? And the IPs of all those machines?

gvdhoorn gravatar image gvdhoorn  ( 2018-10-29 10:09:54 -0500 )edit