Ask Your Question
0

Local path planner (dwa) has strange behavior

asked 2018-10-10 13:48:06 -0600

Hi there!

I am trying to let a robot with omni-directional drive (ridgeback) follow a global path generated with global_planner::GlobalPlanner from navigation package. I am using the ridgeback_gazebo simulation for this. The local planner is dwa_local_planner::DWAPlannerROS. I am using standard parameters for both global and local planners as well as the cost maps from ridgeback package (see here), but also tried to modify multiple parameters. However, I get the strange behavior that sometimes the robot stops even if no object is near and turns on point. This can be seen here at 0:20 : Video.

I would love to know why this occurs. I also tried TrajectoryPlannerROS and set the weights such that following the global path has extremely high priority, but unfortunately with the same behavior.

Platform: Ubuntu16.04 with ROS Kinetic Versions: Everything installed from apt in the last 7 days

Video description: This is a recorded map from the ridgeback_gazebo standard simulation environment, yellow displays the global path, blue the local path and the local costmap can be seen. I am using amcl / map_server for localization. Thank you for your time!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-10-10 16:02:28 -0600

shiv_rar gravatar image

Hey, just did a quick look at your params and just had some minor advice on what you could adjust, to kind of improve.

First thing is the inflation layer:

inflation_radius: 0.25

This should be comparable to the full size the robot footprint, in your case (0.96 length and 0.8 width).

From how the costmap keep out and decay regions work having a small inflation_radius in comparison to the footprint is going to cause some problems when it tries to make that U - turn like movement in the global plan.

Further reading here: http://wiki.ros.org/costmap_2d

My recommendation is to try adjusting the parameters of the inflation layer like so:

inflation_layer:

 enabled:              true
 cost_scaling_factor:  0.3  # exponential rate at which the obstacle cost drops off (default: 10)
 inflation_radius:     1.0

If this doesn't solve your planning issue is it possible to post a screenshot or error messages that come up on the command line during the execution?

edit flag offensive delete link more

Comments

First of all, thank you so much for your help!

I modified the inflation layer params to your suggested params. This definitely helps. However, at certain angles, the behavior still occurs, even with inflation_radius: 2.0

Screenshot

JulienKindle gravatar imageJulienKindle ( 2018-10-11 01:13:22 -0600 )edit

Hey, maybe try reducing the update_frequency in the costmap configs to remove the warning and see if that helps to.

shiv_rar gravatar imageshiv_rar ( 2018-10-11 08:30:28 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-10-10 13:46:33 -0600

Seen: 117 times

Last updated: Oct 10 '18