roslaunch via gdb not working

asked 2018-08-23 13:45:49 -0500

Avner gravatar image

Hi

I am trying to run roslaunch with gdb I followed the instructions in here and changed from:

<node name="my_mapping_node" pkg="my_mapping" cwd="node" type="my_mapping_node" output="screen">

to

<node name="my_mapping_node" pkg="my_mapping" cwd="node" type="my_mapping_node" launch-prefix="gdb -ex run --args" output="screen">

I'm getting an error

RLException: Roslaunch got a No such file or directory error while attempting to run

gdb -ex run --args /home/avnerm/catkin_ws/devel/lib/my_mapping/my_mapping_node __name:=my_mapping_node __log:=/home/avnerm/.ros/log/bf9af474-a593-11e8-b43e-74d02b912ce1/my_mapping_node-1.log

Please make sure that all the executables in this command exist and have executable permission. This is often caused by a bad launch-prefix

When I run the gdb command directly from the terminal the program runs ok., e.g.

gdb -ex run --args /home/avnerm/catkin_ws/devel/lib/my_mapping/rm_mapping_node __name:=rm_mapping_node

So I assume it is some setting that is needed for roslaunch I tried setting "export ROS_HOSTNAME=localhost" as recommended in one of the sites but this didn't help.

How can I run roslaunch via gdb?

Thanks, Avner

edit retag flag offensive close merge delete

Comments

Did you get to know ?

Riss69 gravatar imageRiss69 ( 2019-09-15 02:13:53 -0500 )edit