Ask Your Question
2

Clock server as nodelet

asked 2018-08-21 08:36:17 -0500

Myzhar gravatar image

updated 2018-08-21 08:36:50 -0500

I have a nodelet that should act as clock server when it is started in simulation mode.

My problem is that if I set "use_sim_time" to true the "nodelet_manager" does not start because there is no clock source until my nodelet is started.

How can I solve this "snake biting its tale" problem?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-02-20 10:15:31 -0500

RaphvK gravatar image
  1. Set use_sim_time = false
  2. Start nodelet_manager
  3. Set use_sim_time = true
  4. Load clock server nodelet into nodelet_manager
edit flag offensive delete link more
0

answered 2021-07-29 10:18:54 -0500

lucasw gravatar image

https://github.com/ros/ros_comm/issue... describes this (posted a day later, a link back to this question would have been nice), and then there was a PR fix https://github.com/ros/ros_comm/pull/... to use wall clock that was merged.

(Via https://github.com/stereolabs/zed-ros...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2018-08-21 08:36:17 -0500

Seen: 306 times

Last updated: Jul 29 '21