Navigation stack and odometry

asked 2018-08-17 13:39:53 -0600

hudvin gravatar image

Hello, I am trying to configure ROS for 4W robot. Hardware: 4w platform without encoders, hokuyo ust-10lx and some single board computer. Sofware: Linux Mint 18.3, ROS Kinetic. Currently I run everything on my laptop, motors are not attached at all.

My launch file:

<launch>
  <arg name="use_sim_time" value="false"/>
  <node  pkg="urg_node" type="urg_node" name="lidar" >
    <param name="ip_address" value="192.168.0.10"/>
  </node>

<node pkg="rviz" type="rviz" name="rviz" />
<node pkg="hector_mapping" type="hector_mapping" name="hector_mapping" output="screen"
    map_pub_period="2"
    map_multi_res_levels="3"
    map_update_distance_thresh = "0.1"
    map_size="20000">
  <param name="map_resolution" value="0.050"/>
  <param name="pub_map_odom_transform" value="true"/>
  <param name="map_frame" value="map" />
  <param name="base_frame" value="base_link" />
  <param name="odom_frame" value="odom" />
</node>

<node pkg="tf" type="static_transform_publisher" name="base_to_laser_broadcaster" args="0 0 0 0 0 0 /base_link /laser 100" />

<node pkg="laser_scan_matcher" type="laser_scan_matcher_node"
    name="laser_scan_matcher_node" output="screen">
    <param name="fixed_frame" value = "odom"/>
    <param name="use_alpha_beta" value="true"/>
    <param name="max_iterations" value="20"/>
  </node>

<node pkg="hector_trajectory_server" type="hector_trajectory_server" name="hector_trajectory_server" output="screen"> </node>

<node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
  <rosparam file="costmap_common_params.yaml" command="load" ns="global_costmap" />
  <rosparam file="costmap_common_params.yaml" command="load" ns="local_costmap" />
  <rosparam file="local_costmap_params.yaml" command="load" />
  <rosparam file="global_costmap_params.yaml" command="load" />
  <rosparam file="base_local_planner_params.yaml" command="load" />
</node>
</launch>

It works, I am able to build map, local and global costmap, trajectory is also ok. But I am not sure how to setup NavGoal functionality. Right now after I press 2D NavGoal and choose some point on map I get

[ WARN] [1534422602.652496115]: Control loop missed its desired rate of 20.0000Hz... the loop actually took
0.0871 seconds

I tried to play with params, but this changed nothing. Do I need odometry at this stage?

edit retag flag offensive close merge delete