Ask Your Question
0

Building ROS Navigation from source on Kinetic results in hang

asked 2018-08-09 18:14:27 -0600

lfrailev gravatar image

I've been having issues with building ROS navigation from source on Kinetic, with catkin_make simply hanging at 100% until I hit control-c. I've installed all dependencies through rosdep, cloned the latest source code from the kinetic-devel branch, and tried to use the verbose flag (showed no new helpful info), and the release flag. Below is the output when I hit control-c. I've tried removing the navigation stack and installing the compiled version thorough apt-get which works, but I want to edit and debug the source which leaves this as the only option. Any help or advice would be greatly appreciated.

^Cmake[2]: *** Deleting file '/home/aswerdlow/catkin_ws/devel/lib/costmap_2d/costmap_2d_markers'

make[2]: *** wait: No child processes.  Stop.
make[2]: *** Waiting for unfinished jobs....
make[2]: *** wait: No child processes.  Stop.
make[2]: *** Deleting file '/home/aswerdlow/catkin_ws/devel/lib/costmap_2d/costmap_2d_cloud'
make[2]: *** wait: No child processes.  Stop.
make[2]: *** Waiting for unfinished jobs....
make[2]: *** wait: No child processes.  Stop.
Traceback (most recent call last):
  File "/opt/ros/kinetic/bin/catkin_make", line 296, in <module>
    sys.exit(main())
  File "/opt/ros/kinetic/bin/catkin_make", line 240, in main
    run_command(cmd, make_path)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/catkin/builder.py", line 239, in run_command
CMakeFiles/Makefile2:13132: recipe for target 'f1tenth/navigation/costmap_2d/CMakeFiles/costmap_2d_markers.dir/all' failed
make[1]: *** [f1tenth/navigation/costmap_2d/CMakeFiles/costmap_2d_markers.dir/all] Error 2
make[1]: *** wait: No child processes.  Stop.
make[1]: *** Waiting for unfinished jobs....
make[1]: *** wait: No child processes.  Stop.
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
    proc.wait()
  File "/usr/lib/python2.7/subprocess.py", line 1392, in wait
    pid, sts = _eintr_retry_call(os.waitpid, self.pid, 0)
  File "/usr/lib/python2.7/subprocess.py", line 476, in _eintr_retry_call
    return func(*args)
KeyboardInterrupt
edit retag flag offensive close merge delete

Comments

When building things from source, and then asking questions about it, please always mention the hw platform that you're running the build on.

Is this a regular amd64 machine, or something like an RPi?

gvdhoorn gravatar imagegvdhoorn ( 2018-08-10 02:38:47 -0600 )edit

I remember having this problem (hanging at 99-100%) awhile ago on an old T440 laptop (16.04). Don't think it prevented me from using the package though, was just annoying.

stevejp gravatar imagestevejp ( 2018-08-10 08:07:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-09-19 15:58:58 -0600

David Lu gravatar image
edit flag offensive delete link more

Comments

(this is my answer posted in the other thread) I've replicated your problem. It's hanging on the linking step, but you can fix it by adding ${catkin_LIBRARIES} to the target_link_libraries command for costmap-2d_cloud and markers. Not sure why yet, but I'm going to investigate and make a PR.

David Lu gravatar imageDavid Lu ( 2018-09-19 16:27:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-09 18:14:27 -0600

Seen: 205 times

Last updated: Sep 19 '18