Process has died - Exit Code -11

asked 2018-08-07 13:46:32 -0500

th6262 gravatar image

updated 2018-08-07 13:58:19 -0500

jayess gravatar image

Hey everyone! I've checked every other related topic for this problem and also Google, but I cant find the answers.

I was running a project based on the perception pcl on github, which was working perfectly fine, then, without having changed anything inside the project, I get this error when running my launchfile:

[voxel_grid-2] process has died [pid 3613, exit code -11, cmd /opt/ros/melodic/lib/nodelet/nodelet standalone pcl/VoxelGrid ~input:=/crop_box/output __name:=voxel_grid __log:=/home/mert/.ros/log/16c56ad8-9a70-11e8-bef9-055e70fe65d7/voxel_grid-2.log]. log file: /home/mert/.ros/log/16c56ad8-9a70-11e8-bef9-055e70fe65d7/voxel_grid-2*.log

Interestingly this only happens for the voxel grid filter, I'm running a cropbox filter aswell, which is working fine (before the voxel grid filter).

Also this error only appears after I run rviz and try to dispaly the voxel output, or try to do so by rostopic echo.

Additionally I've tried to remake the workspace, reinstalled ros several times, cleaned every unused dependency, and everything has my google search has yielded.

No progress, which is very frustrating, because I can't even find out what the problem seems to be.

Only additional hint I have: between working and not working, the only thing I did was installing Autoware and then removing it again.

I'm on Ubuntu 18.04 with ros melodic.

Thanks in advance!

edit retag flag offensive close merge delete

Comments

1

I'm not sure, but it could very well be that the Autoware installation replaced one of the (binary) dependencies (or transitive dependencies) of the ROS pkgs that crash for you. If they did, and this introduced a ABI incompatibility then crashes such as SEGFAULTs are very likely to occur.

gvdhoorn gravatar image gvdhoorn  ( 2018-08-07 14:00:02 -0500 )edit

Do you know how I would fix something like that? Reinstalling Ros, remaking the packages etc don't seem to help.

Additional info: Process has died happens for the statistical outlier and the voxel grid filter. Does not happen for Cluster Extraction and Passthrough filter! (If I run them standalone)

th6262 gravatar image th6262  ( 2018-08-07 14:40:40 -0500 )edit
1

ROS may not even be the issue. If Autoware setup replaced something like Qt or any other (transitive) dependency you could already run into issues.

But that is of course assuming that this is really the problem.

Does Autoware require a specific PCL version?

gvdhoorn gravatar image gvdhoorn  ( 2018-08-07 14:42:10 -0500 )edit

I believe it does require a specific version to function properly and while researching I found some people talking about Qt. Is there a way to reset Qt to it's previous state, or how would I go about reverting everything back to the original state ? I already removed autoware immediately.

th6262 gravatar image th6262  ( 2018-08-07 15:57:33 -0500 )edit
1

Well, again, assuming that ABI incompatiblity is actually the cause of what you're seeing, there is no really automated way to revert things.

If Autoware did a from-source build of some of its dependencies, figure out where that got installed and remove it. If PPAs were added, remove the pkgs ..

gvdhoorn gravatar image gvdhoorn  ( 2018-08-08 03:39:44 -0500 )edit
1

.. and remove the PPA (there are scripts for that).

Next to that you could try to run a forced --reinstall of all ROS pkgs and their dependencies.

But again: I'm not even sure this is your problem, so it's just one suggestion.

gvdhoorn gravatar image gvdhoorn  ( 2018-08-08 03:40:51 -0500 )edit
1

Btw: different applications needing different versions of dependencies is the kind of thing we try to avoid by using containerisation. For simple applications it may be overkill, but with something like Autoware, with so many dependencies, it would seem like a good idea.

gvdhoorn gravatar image gvdhoorn  ( 2018-08-08 03:41:50 -0500 )edit

Thanks for the suggestions and the advice! I really appreciate it, will try to mentioned methods and report back. The reason must be the autoware installation, the exact cause however is uncertain.

Worst case, would a full reinstallation of my system help (granted I can't solve it otherwise)?

th6262 gravatar image th6262  ( 2018-08-08 05:01:54 -0500 )edit