ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

VREP IMU plugin: Transform argument source_frame in tf2 frame_ids cannot be empty

asked 2018-08-05 05:22:11 -0600

BuxBleed gravatar image

updated 2018-08-05 12:27:34 -0600

gvdhoorn gravatar image

Hello everyone, I am trying to simulate IMU sensor using this IMU plugin in V-REP and visualize results in rviz. https://github.com/bartville/vrep_plu...

But I get following error in rviz:

Invalid argument passed to canTransform argument source_frame in tf2 frame_ids cannot be empty

I think frame_id: ' ' which is empty, is a problem but I don't know how to set it in V-REP or rviz.

Please somebody help, I completely do not understand what is wrong...

edit retag flag offensive close merge delete

Comments

I'm sorry, but you're question does not follow the support guidelines. Please review them, especially the sections about not posting screenshots of console output. If you want to update it to remove the images, let me know and I'll re-open it.

gvdhoorn gravatar image gvdhoorn  ( 2018-08-05 10:18:03 -0600 )edit

Ok I updated post

BuxBleed gravatar image BuxBleed  ( 2018-08-05 11:06:50 -0600 )edit

I would suggest to also show the IMU message as the frame_id field of the header is empty, which seems very much related (or could be a red herring).

gvdhoorn gravatar image gvdhoorn  ( 2018-08-05 11:25:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-05 11:27:17 -0600

gvdhoorn gravatar image

updated 2018-08-05 12:27:07 -0600

Looking at the code for the IMU vrep plugin I don't see it setting the frame_id field. That is most likely the cause here.


Edit:

But how is the function or class property name to set frame_id for given String ?

I'm not sure what you're asking, but to set a proper frame id:

fl.header.frame_id = "<insert some frame name here>"

Edit2: I'm not a VREP user, but the warning shown here sounds like something to pay attention to:

// Quaternion code added
// But It's not from IMU Sensor but from V-Rep simGetObjectQuaternion() Function
// BE CAREFULL When you use it
edit flag offensive delete link more

Comments

But how is the function or class property name to set frame_id for given String ?

BuxBleed gravatar image BuxBleed  ( 2018-08-05 11:38:11 -0600 )edit

Thanks ! That's what I meant.

BuxBleed gravatar image BuxBleed  ( 2018-08-05 11:43:53 -0600 )edit

Thank You very much. That was the problem. Everything works now.

BuxBleed gravatar image BuxBleed  ( 2018-08-05 12:13:09 -0600 )edit
1

It would be very nice if you could submit a pull request against bartville/vrep_plugin_imu that contributs your fix. Future users would then not run into this issue and you'd save them some time (and possibly frustration).

gvdhoorn gravatar image gvdhoorn  ( 2018-08-05 12:25:24 -0600 )edit
gvdhoorn gravatar image gvdhoorn  ( 2018-08-12 01:35:37 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-05 05:22:11 -0600

Seen: 592 times

Last updated: Aug 05 '18