Autonomous navigation, am I missing something ?

asked 2018-07-19 02:16:35 -0500

hamzh.albar@gmail.com gravatar image

Hello everyone,

I'm trying to build an autonomous mapping and navigation robot with rplidar, arduino ( controlling the motors and ROS)

So far I I have got lidar, hector slam, hector exploration planner, and run the simple_exploration_controller and of course rosserial working fine

first question , I'm not sure if that all I need ? Second question , generating the map and running hector exploration planner, and run the simple_exploration_controller, I run rostopic echo cmd_vel but I get zeros and values do not changes !

Any help will be appreciated , thank you

edit retag flag offensive close merge delete

Comments

Please split into two questions. Have you worked through the navigation tutorial

Humpelstilzchen gravatar image Humpelstilzchen  ( 2018-07-19 02:24:06 -0500 )edit

I think the tutorial is different than what I'm trying to do, I don't think I need odometry with hector slam

hamzh.albar@gmail.com gravatar image hamzh.albar@gmail.com  ( 2018-07-19 02:26:48 -0500 )edit

True, but the tutorial won't give you a fully working anyway. The main point here is the understanding how thinks work. I'ld start with odometry and gmapping and later try to replace them with hector mapping.

Humpelstilzchen gravatar image Humpelstilzchen  ( 2018-07-24 02:59:38 -0500 )edit

Hi @hamzh.albar@gmail.com "I run rostopic echo cmd_vel but I get zeros and values do not changes !" I have this issue as well! Did you managed to solve it?

I had this 2 error info on my terminal![ERROR] [1594609714.183423593]: Received plan with zero length [ERROR] [1594609714.183452743]: Could not transform the global plan to the frame of the controller

jjbecomespheh gravatar image jjbecomespheh  ( 2020-07-12 22:57:47 -0500 )edit