Error connecting to Hokuyo: Could not open network Hokuyo

asked 2018-07-13 08:05:44 -0600

pers gravatar image

updated 2019-04-02 21:21:04 -0600

jayess gravatar image

Application/Library version: ros-kinetic-urg-node is already the newest version (0.1.11-0xenial-20180516-164741-0800). Operating System: Ubuntu 16.04 LTS

I want to work with ROS-kinetic with hokuyo ust-20LX. I connected V+ (brown) V- (blue) pins with 12V adaptor. I can not communicate with ethernet. I am getting the error that the Ethernet port could not be opened. I don't know how to solve the problem. can you help me, please?

error output;

$ roscore
$ rosrun urg_node urg_node _ip_address:="192.168.0.10"**

[ERROR] [1531482879.325555899]: Error connecting to Hokuyo: Could not open network Hokuyo:

192.168.0.10:10940

could not open ethernet port

.

$ ping 192.168.0.10

PING 192.168.0.10 (192.168.0.10) 56(84) bytes of data.

From 10.182.78.58 icmp_seq=6 Packet filtered

From 10.182.78.58 icmp_seq=8 Packet filtered

From 10.182.78.58 icmp_seq=9 Packet filtered

From 10.182.78.58 icmp_seq=10 Packet filtered

From 10.182.78.58 icmp_seq=12 Packet filtered

From 10.182.78.58 icmp_seq=13 Packet filtered

^C

--- 192.168.0.10 ping statistics ---

14 packets transmitted, 0 received, +6 errors, 100% packet loss, time 13183ms

pipe 3

edit retag flag offensive close merge delete

Comments

Can you please describe how you're connecting the hokuyo lidar to your computer and what network configuration you're using. You will have to setup the ethernet settings correctly on ubuntu first before this will work.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-07-14 05:21:33 -0600 )edit

I'm not sure how to make a configuration.

I tried the following configuration but didn't work;

auto eth0 iface eth0 inet dhcp

auto eth0:0 iface eth0:0 inet static address 192.168.0.15 netmask 255.255.255.0

is it possible to connect internet with wifi while also connecting lidar with ethernet?

pers gravatar imagepers ( 2018-07-15 10:59:51 -0600 )edit

Plan A: place the output of the command: ifconfig

Plan B: https://acroname.com/blog/resetting-i...

0xd1ma gravatar image0xd1ma ( 2018-07-17 14:36:34 -0600 )edit

According to the output of ping your computers IP address is 10.182.78.58 so it's not on the same subnet as the lidar. I'd recommend using the ubuntu GUI and setting up a manual network with a static IP and subnet mask.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-07-18 06:49:50 -0600 )edit

I configure the ethernet connection; Address: 192.168.0.15 NetMask: 255.255.255.0 Gateway:192.168.0.1

I can connect to the lidar but wifi does not enter the internet when the lidar connection is provided. How can I provide both ethernet and wifi connections at the same time?

pers gravatar imagepers ( 2018-07-18 07:01:17 -0600 )edit

You're in Unix network configuration territory here, but there is plenty of info out there. This question has two good solutions to your internet access problem.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-07-18 10:51:34 -0600 )edit