Ask Your Question
2

use Hokuyo LIDAR with ethernet in ROS

asked 2013-03-21 01:47:26 -0500

ZoltanS gravatar image

updated 2014-01-28 17:15:50 -0500

ngrennan gravatar image

Hi! I got a Hokuyo UTM-30LX-EW which I would like to use with my Turtlebot. The sensor has a power and an ethernet connector. I connected the power to the turtlebot, it seems to be working. I connected the ethernet cable to the wifi router. I can ping the sensors IP from the turtlebot, it seems to be up and running.

I then installed the ros_groovy_laser_drivers package. Then I wanted to try:

roslaunch hokuyo_node hokuyo_test.launch

I get the following warning and error:

[ WARN] [1363863375.680619490]: The use_rep_117 parameter has not been specified and has been automatically set to true.  This parameter will be removed in Hydromedusa.  Please see: http://ros.org/wiki/rep_117/migration
[ERROR] [1363863375.690137879]: Exception thrown while opening Hokuyo. Failed to open port: /dev/ttyACM0. No such file or directory (errno = 2). The requested port does not exist. Is the hokuyo connected? Was the port name misspelled? (in hokuyo::laser::open) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

I wasn't very surprised, since I haven't set the ip of the sensor neither in ROS nor in Ubuntu, so probably that's why I don't have the missing port. I don't know how to set this up. The pages regarding the ros hokuyo node don't mention any IP or ethernet related topics. However, I found a page with the iri_hokuyo driver (http://mediabox.grasp.upenn.edu/roswiki/doc/api/iri_hokuyo_laser/html/), which referst to ethernet and USB ports. Unfortunately, I can't find the iri_hokuyo driver in the ubuntu/ros repositories.

Could someone tell me how should I set up the Hokuyo sensor?

edit retag flag offensive close merge delete

Comments

Are you aware of any differences (pros/conns) of using an ethernet interface over the usb interface? I am currently evaluating Hokuyo sensors for my application and would like to know if there is any advantage in either interface. Apologies for commenting on an old topic. Regards, Chris.

cmeaclem gravatar imagecmeaclem ( 2014-07-31 17:59:45 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
6

answered 2013-03-26 07:46:16 -0500

Chad Rockey gravatar image

updated 2013-03-26 12:39:52 -0500

There's an actively maintained wrapper for urgwidget here: https://github.com/ros-drivers/urg_node

Eventually, this may replace hokuyo_node as the recommended hokuyo driver - even for PR2.

To install:

sudo apt-get install ros-groovy-urg-node

To run (for ethernet):

rosrun urg_node urg_node _ip_address:="192.168.0.10"
edit flag offensive delete link more

Comments

Thanks Chad! It is working!

ZoltanS gravatar imageZoltanS ( 2013-03-28 04:35:53 -0500 )edit

Are there any options for Fuerte? I need to use an ethernet UTM-30LX-EW and it would be convient if it worked with Fuerte.

Airuno2L gravatar imageAiruno2L ( 2013-04-23 04:10:28 -0500 )edit

I'm not aware of any options for Fuerte. You could make a fork and convert it back to rosbuild. :P

Chad Rockey gravatar imageChad Rockey ( 2013-04-23 08:06:39 -0500 )edit

Thanks for the reply. I ended up using this http://devel.iri.upc.edu/docs/labrobotica/hokuyo_laser_2d/index.html But it was quite involved

Airuno2L gravatar imageAiruno2L ( 2013-04-23 08:39:53 -0500 )edit
1

answered 2013-03-21 03:52:58 -0500

Raptor gravatar image

As of 3/21/2013 there is no support for the Multiecho/Ethernet version of the Hokuyo in the hokuyo_node. It is expected to be added in the next version of ROS, which would be Hydro. Here is the issue tracker in GIT: https://github.com/ros-drivers/hokuyo_node/issues/2

They would probably be able to give you a better answer of their status, if you contact them directly.

edit flag offensive delete link more

Comments

Thank you Raptor!

ZoltanS gravatar imageZoltanS ( 2013-03-21 03:57:45 -0500 )edit
Raptor gravatar imageRaptor ( 2013-03-26 03:07:02 -0500 )edit
0

answered 2013-03-22 04:18:06 -0500

ZoltanS gravatar image

Finally, I got it working with the help of Hokuyo customer service. I used the urgwidget_driver, that is a wrapper for ROS (http://sourceforge.net/projects/urgwidget). According to Hokuyo, it might work with the iri_hokuyo_laser driver too in Fuerte, but in Groovy not sure. If I get their consent, I am going to post their step by step guide later here.

edit flag offensive delete link more

Comments

Hi Zoltan, Can you please post the step-by-step guide for how you set up the Hokuyo LiDAR using the urgwidget_driver? I'm facing the same issue. Thanks!

redarean gravatar imageredarean ( 2013-06-24 10:58:12 -0500 )edit

Hi redarean! I didn't get Hokuyo's consent to forward the info, but the solution Chad Rockey posted above works perfectly, try that one, or write to Hokuyo an email, they answered quickly.

ZoltanS gravatar imageZoltanS ( 2013-06-24 20:31:02 -0500 )edit

Hi ZoltanS, Thanks for the prompt reply! I have tried Chad Rockey's solution, but keep getting the following error: "[FATAL] [1372183207.157433441]: Could not open network Hokuyo: 192.168.0.10:10940 could not open ethernet port." Did you also change any IP settings to run urg_node? Thanks again!

redarean gravatar imageredarean ( 2013-06-25 08:02:13 -0500 )edit

Hi redarean, I didn't change the IP of the sensor. I got mine from someone who already used it in windows and it was already configured to 192.168.0.10. There is a windows tool to change the ip if necessary.

ZoltanS gravatar imageZoltanS ( 2013-06-25 08:24:43 -0500 )edit

Hi ZoltanS, I finally figured it out! I needed to assign a static IP to my machine (auto eth0 iface eth0 inet static address 192.168.0.14 netmask 255.255.255.0 gateway 192.168.0.1) Thanks again for all your help! :-)

redarean gravatar imageredarean ( 2013-06-25 10:09:00 -0500 )edit
-1

answered 2013-03-21 02:04:02 -0500

MarkyMark2012 gravatar image

Zoltan,

/dev/ttyACM0 is a serial port.

Look here for details in how to set it up http://www.ros.org/wiki/hokuyo_node

Cheers

Mark

edit flag offensive delete link more

Comments

Hi Mark, thanks, I found this out. Unfortunately, our sensor has only an ethernet port. Zoltan

ZoltanS gravatar imageZoltanS ( 2013-03-21 02:21:02 -0500 )edit

You could consider writing yourself a bit of code to read in off the ethernet port and write out to a virtual serial port - or buy something like a raspberry pi and write a python script - i guess it depends if you can wait for the update Raptor mentioned :)

MarkyMark2012 gravatar imageMarkyMark2012 ( 2013-03-21 04:46:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-03-21 01:47:26 -0500

Seen: 10,025 times

Last updated: Mar 26 '13