Astra: Publish rate is too low (2.7) [closed]

asked 2018-07-10 09:04:40 -0600

Danipol gravatar image

Dear ROS community!

I am using an Astra Mini S with ROS kinetic (version 1.12.13) on Ubuntu 16.04.

I want to capture a point cloud as fast as possible. But that is not working...

When I measure the rate of the topics that come from the astra_camera package all of them seem to be at about ~2.7.

For example: rostopic hz /camera_1/depth/points which returns

average rate: 2.680 
min: 0.373s max: 0.373s std dev: 0.00000s window: 2

But also the raw topics are at that rate: rostopic hz /camera_1/rgb/image_raw

average rate: 2.747
min: 0.360s max: 0.366s std dev: 0.00263s window: 4

Is there a way to control the rate at which the camera publishes messages? Am I missing something?

Thank you for your time in advance Daniel

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Danipol
close date 2018-07-11 08:24:39.581909

Comments

You should get rather constant 30Hz (and I haven't noticed a parameter to change it). Is the camera the only device on its USB-Hub?

NEngelhard gravatar image NEngelhard  ( 2018-07-10 12:28:24 -0600 )edit
1

Hi NEngelhard! Thanks for the answer it turned out to be the data_skip=10 param which was hidden deep in a launch file.

Danipol gravatar image Danipol  ( 2018-07-11 08:24:14 -0600 )edit