Ask Your Question
0

Failed to put the turtlebot in full mode

asked 2012-03-13 10:34:01 -0500

mbeard033 gravatar image

I have the roslaunch turtlebot_bringup minimal.launch running on the turtlebot laptop and the turtlebot dashboard running on my workstation computer but and the icons are green aside from the breakers and the mode icon. When I attempt to switch the turtlebot's mode to full mode i get the error message:

"Failed to put the turtlebot in full mode: service call failed with error: service [/turtlebot_node/set_operation_mode] unavailable"

Any ideas as to why i cannot switch modes?

edit retag flag offensive close merge delete

Comments

Is the mode icon grey or red? Do the breaker icons fail to work as well?

Ryan gravatar image Ryan  ( 2012-03-13 14:23:26 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-03-13 15:13:55 -0500

tfoote gravatar image

updated 2012-03-13 15:24:50 -0500

This type of error can occur if you do not have complete network connectivity between computers. Guide to Network Setup Troubleshooting

This can also happen if you restart the master without restarting the dashboard.

edit flag offensive delete link more
0

answered 2012-03-16 01:08:01 -0500

allenh1 gravatar image

From my experiences, this issue is easily fixed. You ready: restart the robot. If that doesn't work, do this:

roscd turtlebot_bringup
sudo ./[scripts, maybe?]/install.bash <Network interface, probably wlan0>

Then, restart. If that doesn't work, charge your turtlebot.

This happens every once and a while to me as well. I normally play with it until it works. Best of luck, -Hunter A.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-13 10:34:01 -0500

Seen: 451 times

Last updated: Mar 16 '12