Ask Your Question
0

The Intel RealSense R200 camera is not detected by the Turtlebot3 (Waffle)

asked 2018-07-03 18:36:21 -0600

csg gravatar image

updated 2018-07-16 18:09:56 -0600

jayess gravatar image

Hello all,

I am trying to do 3D SLAM using the R200 camera and Turtlebot3 Waffle. I installed the Intel® RealSense™ package following the steps given in http://emanual.robotis.com/docs/en/pl...

When I ran

roslaunch realsense_camera r200_nodelet_rgbd.launch

I receive the following error:

[ERROR] [1530659146.559707562]: /camera/driver - No cameras detected!

The camera was connected to Netmate USB 3.0 (4 port) hub. I tried connecting it directly but I am still getting the same error. Some additional information are:

I am not running inside a VM. The PC and OS specs are:

  • Ubuntu 16.04.4 LTS \n \l
  • 4.13.0-45-generic
  • 64-bit machine

Is the camera recognized on some another platform? I didn't try this particular camera with another device other than the Turtlebot I have.

I am using the short USB cable provided with the camera device.

In here under title Installation Troubleshooting this particular error is mentioned. But as far as I understood, the solution provided applies to the case where the camera is connected to a PC not a Turtlebot, hence I didn't try the provided solution.

Any help is appreciated.

edit retag flag offensive close merge delete

Comments

I suggest following Installation Troubleshooting in ROS WiKi

Darby Lim gravatar imageDarby Lim ( 2018-07-03 18:50:18 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-07-07 23:14:04 -0600

csg gravatar image

updated 2018-07-23 18:49:47 -0600

I managed to solve this problem. The issue was to do with the permissions given to the user by the system admin. I asked the lab manager (who has sudo access) to give permission to my user ID to access the git cloned packages. Then I repeated these steps inside the second workspace that I created inside the Turtlebot.

$ cd catkin_ws/src
$ git clone https://github.com/intel-ros/realsense.git
$ cd realsense
$ git checkout 1.8.0
$ cd catkin_ws && catkin_make -j2

and the camera started working. Hope this helps anyone else who has the same issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-07-03 18:36:21 -0600

Seen: 340 times

Last updated: Jul 23 '18