Ask Your Question
0

Velodyne HDL32 FPS issue

asked 2018-06-20 10:16:46 -0600

StevenCoral gravatar image

updated 2018-06-20 13:59:32 -0600

Hi Pals,

I've been using the latest velodyne package in order to receive data from the HDL-32E. I am using ubuntu 14.04.5 with a ROS indigo installation.

The driver mostly works fine, getting the desired 15Hz on a 900 RPM lidar rotation (and respectfully other Hz corresponding to other RPMs). This was checked via "rostopiz hz".

Using the Lidar on it's regular configuration generates ~50k points per frame, which is too much for me, especially considering I only need the front +-60 degrees (120 deg in total, which is a third of the whole 360 deg sweep). So I put that information into the corresponding slots inside the lidar's web GUI (you can choose the desired sweep angle), and I do get the desired sweep when I look in Rviz.

Now for the problem: I get the same amount of points per message, with the messages coming in at 1/3rd of the rate. The lidar is accumulating points for 3 revolutions and then publishing 1 message. Tests I've made show that this is probably a driver issue and not hardware. I found no parameter to change that might affect this behavior.

Here are some screenshots, with the Rviz, launch file, and velodyne web gui open.

Note that for full 360deg you get 15 fps, on a 120deg fan you get 5 fps (360/3->15/3), and on a 72deg fan you get 3 fps.

https://drive.google.com/open?id=1m0C.. .

https://drive.google.com/open?id=12B6.. .

https://drive.google.com/open?id=1qy8.. .

If anyone ever tried to limit the sweep before and get it to work, I'de love to hear.

Thanks in advance, Steve

EDIT: adding pics directly. Firefox gave me trouble for some reason

image description

image description

image description

edit retag flag offensive close merge delete

Comments

1

Can you please attach the screenshots to your question directly instead of linking to google drive?

gvdhoorn gravatar imagegvdhoorn ( 2018-06-20 10:36:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-06-20 11:34:38 -0600

stevejp gravatar image

updated 2018-06-20 11:38:09 -0600

If memory serves, the ros velodyne driver calculates an expected number of packets per scan based on receiving data for a full 360 degrees. So if you are only sending 1/3 the data packets every rotation, it will take 3 rotations before ros will register enough packets to publish a scan. This lines up with your notes on observed topic publishing frequency.

This is a little hacky, but can you try changing the rpm param in your launch file to be 2700 instead of 900 and report back (keep the actual rpm setting in the web interface at 900)?

edit flag offensive delete link more

Comments

Actually this makes a lot of sense. Tried it and it works! thanks.

StevenCoral gravatar imageStevenCoral ( 2018-06-20 14:00:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-20 10:16:46 -0600

Seen: 260 times

Last updated: Jun 20 '18