Ask Your Question
0

Turtlebot3 ROS bringup erro

asked 2018-06-14 15:21:30 -0600

Eamon gravatar image

updated 2018-06-14 15:40:07 -0600

jayess gravatar image

I am currently running ROS kinetic on Ubuntu 16.04, and have been following instructions from the ROBOTIS emanual on a new turtlebot 3 waffle pi. The camera bring up is always successfull, but the lidar and core fail, whether I do a full bring up or do them individually.

Lidar error: [ERROR] [1529006388.873017851]: An exception was thrown: open: Permission denied [turtlebot3_lds-2] process has died [pid 2322, exit code 255, cmd /home/eamon/catkin_ws/devel/lib/hls_lfcd_lds_driver/hlds_laser_publisher __name:=turtlebot3_lds __log:=/home/eamon/.ros/log/8ab682e4-700c-11e8-b243-40a3cc6cf0cf/turtlebot3_lds-2.log]. log file: /home/eamon/.ros/log/8ab682e4-700c-11e8-b243-40a3cc6cf0cf/turtlebot3_lds-2*.log

Core error (repeats indefinitely):

[ERROR] [1529006392.159372]: Creation of publisher failed: nav_msgs ROS path [0]=/opt/ros/kinetic/share/ros ROS path [1]=/home/eamon/catkin_ws/src ROS path [2]=/opt/ros/kinetic/share [INFO] [1529006392.178379]: Setup publisher on joint_states [sensor_msgs/JointState] [INFO] [1529006392.198307]: Setup publisher on battery_state [sensor_msgs/BatteryState] [INFO] [1529006392.231115]: Setup publisher on magnetic_field [sensor_msgs/MagneticField] the rosdep view is empty: call 'sudo rosdep init' and 'rosdep update' [INFO] [1529006393.989115]: Setup publisher on /tf [tf/tfMessage] [INFO] [1529006394.023258]: Note: subscribe buffer size is 1024 bytes [INFO] [1529006394.024698]: Setup subscriber on cmd_vel [geometry_msgs/Twist] [INFO] [1529006394.073001]: Setup subscriber on sound [turtlebot3_msgs/Sound] [INFO] [1529006394.110597]: Setup subscriber on motor_power [std_msgs/Bool] [INFO] [1529006394.147596]: Setup subscriber on reset [std_msgs/Empty] [INFO] [1529006394.956246]: Connected to OpenCR board! [INFO] [1529006394.959464]: This core(v1.2.0) is compatible with TB3 Waffle or Waffle Pi [INFO] [1529006394.966637]: Start Calibration of Gyro [INFO] [1529006397.507985]: Calibration End [ERROR] [1529006397.524993]: Tried to publish before configured, topic id 129 [INFO] [1529006397.540917]: Setup publisher on sensor_state [turtlebot3_msgs/SensorState] [INFO] [1529006397.547413]: Setup publisher on version_info [turtlebot3_msgs/VersionInfo] [INFO] [1529006397.553062]: Setup publisher on imu [sensor_msgs/Imu] [INFO] [1529006397.560466]: Setup publisher on cmd_vel_rc100 [geometry_msgs/Twist]

After these failed bring ups I am still able to view and control the bot in Rviz, but the mapping does not work (presumably becuase the lidar does not bring up) And the lidar does begin spinning on start up so I do not believe it to be a wiring error.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-06-14 16:37:04 -0600

Hi Eamon,

This seems to be a USB permission error.

TurtleBot3's Lidar and OpenCR are connected to RaspberryPi's USB. Did you make the USB settings mentioned in the e-Manual? First, check the related links and try again on TurtleBot PC.

http://emanual.robotis.com/docs/en/pl...

edit flag offensive delete link more

Comments

This fixed the lidar bringup error, but I still get the repeating errors in the bring up.

ROS path [0]=/opt/ros/kinetic/share/ros ROS path [1]=/home/eamon/catkin_ws/src ROS path [2]=/opt/ros/kinetic/share

Eamon gravatar imageEamon ( 2018-06-15 09:15:49 -0600 )edit

This error also comes up as well:

Eamon gravatar imageEamon ( 2018-06-15 09:16:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-14 15:21:30 -0600

Seen: 516 times

Last updated: Jun 14 '18