Ask Your Question
0

Unable to install rosserial on Ubuntu 18.04, using ROS melodic

asked 2018-06-04 02:36:47 -0500

ashutosh007 gravatar image

I am trying to interface ROS melodic and arduino. I tried installing rosserial from source but still coulnt see ros_lib in examples. I also could not find commands to install for melodic, that is why I went for source file. Thank you.

edit retag flag offensive close merge delete

Comments

i think have the same problem, did you solve it???? I'm using ROS melodic on ubuntu 18.04

I tried to install rosserial with:

sudo apt-get install ros-melodic-rosserial
sudo apt-get install ros-melodic-rosserial-arduino

i get the error:

Get:1 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 binutils-avr amd64 2.26.20160125+Atmel3.6.0-1 [1.475 kB]
Err:2 http://packages.ros.org/ros/ubuntu bionic/main amd64 ros-melodic-rosserial-msgs amd64 0.8.0-0bionic.20190318.181339
  404  Not Found [IP: 2600:3402:200:227::2 80]
colidar gravatar imagecolidar ( 2019-06-11 03:54:11 -0500 )edit

@colidar: you're issue would appear to be due to (for some reason) Ubuntu trying to use the IPv6 address to reach packages.ros.org, and failing. @ashutosh007 describes a very different problem.

Please post your problem as a new question.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-11 03:56:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-27 08:12:01 -0500

Sohan_Anisetty gravatar image

I had the same problem. I followed this link: http://answers.ros.org/question/32503... Now it is working for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-04 02:36:47 -0500

Seen: 363 times

Last updated: Jun 04 '18