ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Plugin from package [mapping_rviz_plugin] not loaded for display class [mapping_rviz_plugin::PolygonalMapDisplay] [closed]

asked 2012-03-06 21:57:35 -0500

owh gravatar image

updated 2012-03-14 23:35:12 -0500

I am testing the mit-kinect hand interaction demo. I managed to get the demo running and displayed hands on rviz. However, the "skeletonmap" could not be displayed due to:

Plugin from package [mapping_rviz_plugin] not loaded for display class [mapping_rviz_plugin::PolygonalMapDisplay]

I tried "rosmake mapping_rviz_plugin" and the problem remains. Tried re-"rosmake rviz", tried start system, the problem persists - the PolygonalMap3 is in red with the above error message.

Hopeful for some help here. I am on ros-electric and Ubuntu 11.10 x64.


I am still struggling with this problem. Any help?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-01-02 12:52:57

3 Answers

Sort by ยป oldest newest most voted

answered 2012-03-12 16:47:26 -0500

owh gravatar image

I do not know why I am not able to edit my question, neither am I able to comment on your answers. This happens after sign in. Anyway, I use this space to respond to answers.

@abrsefid. Thanks, did that many times without error, however the plugin still doesn't load in rviz.

@egiljones. Did that as well, arm-navigation stack is there, mapping_rviz_plugin is there (rosmaked), rviz is there (did rosmake as well), however the plugin just doesn't load in rviz.

Any more help please?

edit flag offensive delete link more


I asked a question about the definition of PolygonalMap in Electric a while back. Perhaps this is why it won't work. Just FYI, mit-ros-pkg page only lists cturtle and diamondback as supported versions.

jarvisschultz gravatar image jarvisschultz  ( 2012-03-19 13:34:58 -0500 )edit

answered 2012-03-12 06:30:15 -0500

egiljones gravatar image

The mapping_rviz_plugin package is in the arm_navigation stack - did you try to 'sudo apt-get install ros-electric-arm-navigation'?

edit flag offensive delete link more

answered 2012-03-12 02:06:09 -0500

abrsefid gravatar image

you need to rosmake mapping_rviz_planning

edit flag offensive delete link more

Question Tools


Asked: 2012-03-06 21:57:35 -0500

Seen: 827 times

Last updated: Mar 14 '12