Rosbridge, trying to connect to service, but cannot be found

asked 2018-04-23 07:54:38 -0600

ros_learner gravatar image

updated 2018-04-23 08:37:19 -0600

I'm trying to connect to a service, but I get an InvalidServiceException, saying: beginner_tutorials/AddTwoInts does not exist. The connection itself seems to go OK, according to the terminal.

When I consult rossrv, I see the service. Some googling got me to this: https://answers.ros.org/question/1682... , but when I try to

rosrun rosapi rosapi

I get slapped with an error:

[rosrun] Couldn't find executable named rosapi below /opt/ros/kinetic/sahre/rosapi

[rosrun] Found the following, but they're either not files,

[rosrun] or not executable:

[rosrun] /opt/ros/kinetic/share/rosapi

I installed rosbridge according to http://wiki.ros.org/rosbridge_suite and http://wiki.ros.org/rosbridge_suite/T...

So I ended up doing 2 installations, one of server and one of suite. I sourced it, and when I start rosbridge using: roslaunch rosbridge_server rosbridge_websocket.launch I see rosapi in the list of NODES: rosapi (rosapi/rosapi_node).

My linux is ubuntu 16.04.

Best,

Update:

I tried the command

rosrun rosapi rosapi_node

That seemed to start rosapi, but I still get the same error.

Furthermore: publishing messages from my windows environment (C#) to the ubuntu DOES work :)

edit retag flag offensive close merge delete