Ask Your Question
1

Why roscore takes such a long time to be created?

asked 2018-04-11 03:47:45 -0500

MTV1368 gravatar image

I initially used "$roscore to"create the master and it did take 10 seconds to be done. However when I tried an hour later to see the detail of the node by "$rosnod list" the following message appeared: "ERROR: Unable to communicate with the master!" I did try to create another master node by $roscore but it took half o=an hour and still yet to be showed. Can someone kindly explain why it takes such a long time?

Thank you in advance

best regards

edit retag flag offensive close merge delete

Comments

1

Did you ever set one of the environment variables ROS_IP, ROS_HOSTNAME, ROS_MASTER_URI or similar?

gvdhoorn gravatar image gvdhoorn  ( 2018-04-11 05:22:02 -0500 )edit

Yes I did it once and it was ok it did work but I closed terminal due to an error and it didn't work in the same manner.

MTV1368 gravatar image MTV1368  ( 2018-04-11 09:55:06 -0500 )edit
1

Did you add those to $HOME/.bashrc?

gvdhoorn gravatar image gvdhoorn  ( 2018-04-11 09:56:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-10-27 13:50:20 -0500

Haresh gravatar image

i removed ROS_IP, ROS_MASTER_URI from ~/.bashrc file and it works

edit flag offensive delete link more
0

answered 2021-12-01 01:03:32 -0500

Hetal Priyadarshi gravatar image

Did you change your Wifi recently? or fiddle with the home/.bashrc ?

its taking so long because it can't find the ROS server at the mentioned IP in ROS_HOSTNAME, ROS_MASTER_URI etc.

To solve this edit .bashrc to this:

export ROS_MASTER_URI=http://127.0.0.1:11311

export ROS_HOSTNAME=127.0.0.1

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-11 03:47:45 -0500

Seen: 1,476 times

Last updated: Dec 01 '21