Costmap2DROS transform timeout

asked 2018-03-19 20:17:30 -0500

julimen5 gravatar image

updated 2018-03-20 12:52:03 -0500

Hi guys!

I'm having some troubles with the navigation stuff of my own robot. When I run roslaunch hector_exploration_node exploration_planner.launch I get this WARN and NOTHING happend

 WARN] [1521508876.605722000]: Costmap2DROS transform timeout. Current time: 1521508876.6055, global_pose stamp: 1521508876.2576, tolerance: 0.3000

[ WARN] [1521508876.606342675]: Could not get robot pose, cancelling reconfiguration

So I though a bit about this and I realize i did not initialize the pose_estimation node so

roslaunch hector_pose_estimation hector_pose_estimation.launch

and i get this

ERROR: cannot launch node of type [hector_pose_estimation/pose_estimation]: can't locate node [pose_estimation] in package [hector_pose_estimation]

Anyone can help me?

edit retag flag offensive close merge delete

Comments

How did you install hector_localization? Have you made any changes to it? I just tested roslaunch hector_pose_estimation hector_pose_estimation.launch on a clean build and it worked fine.

stevejp gravatar image stevejp  ( 2018-03-20 06:54:00 -0500 )edit

sudo apt-get install ros-kinetic-hector-localization I don't know why it fails. When I do roscd hector-localization I just have one file package.xml and nothing else.

julimen5 gravatar image julimen5  ( 2018-03-20 08:20:15 -0500 )edit