ROS says it can't find any executable file

asked 2018-03-16 15:19:04 -0600

Orlandog95 gravatar image

I made a .cpp executable and put it in the src folder and modified the make file to add executable as in the tutorial, but when I run the launch file it runs the node but then exits because it says it didn't find the executable file. I don't know if there have to be more changes to the make file or if the problem lies someplace else. Im running ROS indigo. Thank you

edit retag flag offensive close merge delete

Comments

Have you used ┬┤catkin_make┬┤ afterwards?

JaFeKl gravatar imageJaFeKl ( 2018-03-17 14:50:31 -0600 )edit

yes, I ran catkin_make and ran the launch file and it starts normally and opens the node, but because it says it doesn't find any executable in the src folder it exits, but it is there.

Orlandog95 gravatar imageOrlandog95 ( 2018-03-17 19:13:47 -0600 )edit
2

maybe

source ./devel/setup.bash

in your catkin

hamid gravatar imagehamid ( 2018-03-18 00:39:23 -0600 )edit

Please provide more information:

  • How did you create an executable file and why are you putting it in src folder? I am guessing you are referring to a simple .cpp source file, and not a real .exe file.
  • Which tutorial are you referring to?
  • Can you provide your CMakeLists.txt file?
dljubic gravatar imagedljubic ( 2018-03-18 07:46:49 -0600 )edit