Ask Your Question
0

imu rate is not constant

asked 2018-03-06 11:04:48 -0600

sarra.elhadj gravatar image

Hi everyone,

I am working on a project which consists in publishing imu data (after reading them from mpu9250) with timestamp, I am using three talker nodes, for accelero, gyro and magneto, I am launching the three files. The problem is that I am guetting data with a rate which is not constant each time. For example, Am supposed to get data every 10ms( fixed with rospy.rate), instead am guetting it sometimes 9.8ms, 9.7ms,..

Is this logic?

edit retag flag offensive close merge delete

Comments

Why do you have three talker nodes for a single sensorboard?

NEngelhard gravatar imageNEngelhard ( 2018-03-06 12:46:11 -0600 )edit

linux isn't the strong real-time system. the rate is always variated depends on the internal process.

0xd1ma gravatar image0xd1ma ( 2018-03-07 02:01:04 -0600 )edit

@NEngelhard yes I wrote them in one single node, but since rate was variant I wanted to try if it changes something. In all cases rate is not const. Thanx for ur reply

sarra.elhadj gravatar imagesarra.elhadj ( 2018-03-07 07:31:46 -0600 )edit

@0xd1ma yes am working on Raspberry Pi3 and Navio2 as a sensor board.

sarra.elhadj gravatar imagesarra.elhadj ( 2018-03-07 07:33:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-08 09:59:56 -0600

sarra.elhadj gravatar image

May this be an issue of using Python and not C++??

edit flag offensive delete link more

Comments

Please don't use an answer to leave a comment. This isn't a forum. Please use comments or update your question.

jayess gravatar imagejayess ( 2018-03-08 11:00:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-06 11:04:48 -0600

Seen: 64 times

Last updated: Mar 08 '18