Ask Your Question
0

Issue during 'roslaunch turtlebot_gazebo turtlebot_world.launch'

asked 2018-03-06 01:55:32 -0600

Chput gravatar image

updated 2019-04-22 13:04:04 -0600

jayess gravatar image

Hello everybody!

I have Ubuntu 16.06 Xenial and ROS Kinetic installed. I want to launch gazebo turtlebot simulation with a command:

roslaunch turtlebot_gazebo turtlebot_world.launch

At first, I installed turtlebot using:

sudo apt-get install ros-kinetic-turtlebot ros-kinetic-turtlebot-apps ros-kinetic-turtlebot-interactions ros-kinetic-turtlebot-simulator ros-kinetic-kobuki-ftdi ros-kinetic-rocon-remocon ros-kinetic-rocon-qt-library ros-kinetic-ar-track-alvar-msgs

Then launching gazebo turtlebot simulation I got a typical error:

[turtlebot_world.launch] is neither a launch file in package [turtlebot_gazebo] nor is [turtlebot_gazebo] a launch file name
The traceback for the exception was written to the log file

After that I installed without deleting the previous turtlebot software:

sudo apt-get install ros-kinetic-turtlebot-gazebo

Everything was fine and then I tried again and got:

..

. logging to /home/aleks/.ros/log/98e51c20-20bd-11e8-91d8-ccb0dacbc15b/roslaunch-aleks-Aspire-E5-575G-15388.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Invalid <arg> tag: environment variable 'TURTLEBOT_GAZEBO_WORLD_FILE' is not set
.
Arg xml is <arg default="$(env TURTLEBOT_GAZEBO_WORLD_FILE)" name="world_file"/>
The traceback for the exception was written to the log file
edit retag flag offensive close merge delete

Comments

HI there, I just met the same question, and I followed the instruction to set the source, still cannot run the program, could you please give me some advice??

aliu04 gravatar imagealiu04 ( 2020-01-15 10:55:16 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-03-06 02:16:11 -0600

Chput gravatar image

updated 2018-03-06 02:17:33 -0600

Completely forgot to source devel/setup.bash Issue solved.

edit flag offensive delete link more
1

answered 2018-03-06 02:10:05 -0600

jayess gravatar image

A Google search gave me #q208287. In that answer, @130s stated

Turtlebot utilizes environment variables that are set by env hook. See this tutorial.

edit flag offensive delete link more
0

answered 2019-04-22 07:38:07 -0600

mechaliomar gravatar image

yes that's right

edit flag offensive delete link more

Comments

What does this mean? Is this supposed to be a comment?

jayess gravatar imagejayess ( 2019-04-22 13:04:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-06 01:55:32 -0600

Seen: 1,124 times

Last updated: Apr 22 '19